Opened 5 years ago

Closed 4 years ago

#945 closed defect (fixed)

rtsp sends wrong session id in keep-alive request

Reported by: twinther Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: rtsp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have a problem with rtsp:// streams that stops after about 70-80 seconds (after the first timeout expires). It is a stream of a live tv channel, fx. rtsp://62.242.233.129/rtpencoder/e20_wcif.sdp?ir=850000&life=0&ttl=20&ip&gtime=1327344362&tn=key5&guid=bCZhgCggQC//0Q==ACEow69c&da=0&key=/dznsJ2d8FNZV0iCnjmWqw==

The links only works for a short time and only for Danish YouSee? customers, so I will attach a tcpdump of the traffic.

It looks like the OPTIONS requests that is sent near the end of the tcpdump file is sending a wrong session id. It actually appears to be the value of the ETag header value from the DESCRIBE request near the top of the tcpdump.

the CSeq also starts over for this keep alive request, so this line is logged when the stream stops playing:
[rtsp @ 0x7ff5f80008e0] CSeq 10 expected, 1 received.

I have had a stab at the code, but I haven't been able to figure out why this is happening.

Please let me know if I can provide further info, help with testing, etc..

The streams plays without a problem in totem using the gstreamer rtsp implementation.

Attachments (2)

ffplay.log (5.6 KB) - added by twinther 5 years ago.
ffplay.dump.7z (2.4 MB) - added by twinther 5 years ago.

Change History (4)

Changed 5 years ago by twinther

Changed 5 years ago by twinther

comment:1 Changed 4 years ago by twinther

Please close this ticket, it was fixed in commit e3822886ebb3ae97bdae9be264d891f1d35c960b

Br.
Tommy

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1a6b9a.

Note: See TracTickets for help on using tickets.