Opened 5 years ago

Closed 5 years ago

Last modified 9 months ago

#6097 closed defect (invalid)

Get milliseconds information for filenames in image sequence

Reported by: clic Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: image2
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary:
It is not possible to generate filenames in image sequences containing milliseconds information.

How to reproduce:

% ffmpeg -f dshow -i video="Integrated Webcam" img_%07d.jpg

.. records JPEGs using sequence pattern

% ffmpeg -f dshow -i video="Integrated Webcam" -strftime 1 img_%Y-%m-%d_%H-%M-%S.jpg

.. uses strftime to generate date information in filenames - but does not support milliseconds

ffmpeg 3.2.2
built from zeranoe

Change History (2)

comment:1 by Carl Eugen Hoyos, 5 years ago

Component: ffmpegundetermined
Resolution: invalid
Status: newclosed
Type: enhancementdefect

Afaict, there is no way to get the current time with a higher precision than seconds in POSIX on which FFmpeg depends.
If you want the timestamps (that have a higher precision than seconds) in the output file name, this is a duplicate of ticket #1452.

comment:2 by Martin, 9 months ago

any progress on millisecs especially in regards of VFR?

Note: See TracTickets for help on using tickets.