Opened 5 years ago

Last modified 16 months ago

#1452 reopened enhancement

image2 to support %t

Reported by: burek Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: image2
Cc: OmegaPhil@startmail.com, rogerdpack@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Parameter %t in the output file name (just like %d) could be used to store the time stamp info of the current frame being written in the file. It could follow the same syntax like %d for formatting.

It also might be used as an input parameter, but the list of matching input files would have to be sorted first, I guess, to have a correct sequence of input files.

Attachments (1)

0001-Added-the-option-to-extract-images-with-timecode-as-.patch (5.2 KB) - added by marcusjohansson 3 months ago.
Fix for %t as timestamp

Download all attachments as: .zip

Change History (8)

comment:1 in reply to: ↑ description Changed 5 years ago by saste

  • Component changed from undetermined to avformat
  • Keywords image2 added
  • Status changed from new to open

Replying to burek:

Parameter %t in the output file name (just like %d) could be used to store the time stamp info of the current frame being written in the file. It could follow the same syntax like %d for formatting.

It also might be used as an input parameter, but the list of matching input files would have to be sorted first, I guess, to have a correct sequence of input files.

This looks a lot like #1969.

comment:2 Changed 5 years ago by burek

Yes, I guess the ticket #1969 is a duplicate of this ticket (this one was opened 7 months ago).

The idea is just to have a way to use the time stamps rather than the list of sequential numbers, in the input/output file name. The code for the input files might be a bit trickier than the code for the output output, but I guess it can be solved using file globing (replacing %t with *) or similar filtering.

comment:3 follow-up: Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
  • Version changed from unspecified to git-master

I believe this was implemented by Ramiro Polla in 454c89dd

comment:4 in reply to: ↑ 3 Changed 4 years ago by saste

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to cehoyos:

I believe this was implemented by Ramiro Polla in 454c89dd

No, that commit allows to set the system time in the output file name, it's not the same as the timestamp, and only in the output.

comment:5 Changed 2 years ago by OmegaPhil

  • Cc OmegaPhil@startmail.com added

comment:6 Changed 16 months ago by rogerdpack

  • Cc rogerdpack@gmail.com added

comment:7 Changed 16 months ago by rogerdpack

Here is a github that at least started on it once, looks OK here:

http://stackoverflow.com/a/8953789/32453

Changed 3 months ago by marcusjohansson

Fix for %t as timestamp

Note: See TracTickets for help on using tickets.