Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5589 closed defect (fixed)

Unsharp broken with high matrix size.

Reported by: YellowOnion Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: unsharp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Corrupt colours with software unsharp filter from values above 13, and other-parity breaking features with opencl (contrast worse, softening effect).

Comparative export from GIMP.

Attachments (6)

test-gimp.png (302.3 KB) - added by YellowOnion 3 years ago.
GIMP example.
test-msize-15.png (345.2 KB) - added by YellowOnion 3 years ago.
Where the bug starts to appear.
test-nofilter.png (342.2 KB) - added by YellowOnion 3 years ago.
the original picture.
test-opencl.png (285.8 KB) - added by YellowOnion 3 years ago.
OpenCL example exhibiting lowered contrast, and inverse of the desired effect.
test-unsharp.png (92.1 KB) - added by YellowOnion 3 years ago.
software looks like a maze puzzle.
ffmpeg-opencl.log (16.7 KB) - added by YellowOnion 3 years ago.
log file for all the commands etc.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by YellowOnion

GIMP example.

Changed 3 years ago by YellowOnion

Where the bug starts to appear.

Changed 3 years ago by YellowOnion

the original picture.

Changed 3 years ago by YellowOnion

OpenCL example exhibiting lowered contrast, and inverse of the desired effect.

Changed 3 years ago by YellowOnion

software looks like a maze puzzle.

Changed 3 years ago by YellowOnion

log file for all the commands etc.

comment:1 Changed 3 years ago by cehoyos

Do I understand correctly that this issue is only reproducible with OpenCL?

comment:2 Changed 3 years ago by richardpl

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by cehoyos

  • Keywords unsharp added
  • Version set to git-master
Note: See TracTickets for help on using tickets.