Opened 3 years ago

Closed 3 years ago

#5588 closed defect (duplicate)

Attempting to use scale_npp filter results in "impossible to convert between formats"

Reported by: rednaxela Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

As best as I can tell, trying to use the scale_npp filter is always resulting in an error such as the following for me:

Impossible to convert between the formats supported by the filter 'graph 0 input from stream 0:0' and the filter 'auto-inserted scaler 0'
Error opening filters!

An example command line is

ffmpeg -i input_file.mkv -filter:v "scale_npp=w=1316:h=1080:format=same:interp_algo=lanczos" -codec:v libx264 output_file.mkv

This seems to happen regardless of what sort of input file I try. Initially was using a rgb24 color space input file, and thinking that might have been the problem tried a yuv420p input file, with the same result.

This is based upon a local build of the current git version, built under MSYS2 and which includes libnpp support.

A full log is attached.

Maybe this is user error rather than a bug? I can't see what I've done wrong though.

Change History (1)

comment:1 Changed 3 years ago by rednaxela

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, duplicate submit of #5587

Note: See TracTickets for help on using tickets.