Opened 6 years ago

Closed 6 years ago

#5590 closed defect (duplicate)

Schematron validation not successful. Period element shall have an id.

Reported by: Ole Andre Birkedal Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: dash
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Using http://www-itec.uni-klu.ac.at/dash/?page_id=605 for validating DASH manifests I get the current error when validating the attached MPD file from FFmpeg:

<svrl:failed-assert test="if (not(@id) and ancestor::dash:MPD/@type = ‘dynamic’) then false() else true()"
location="/*[local-name()='MPD' and namespace-uri()='urn:mpeg:dash:schema:mpd:2011']/*[local-name()='Period' and namespace-uri()='urn:mpeg:dash:schema:mpd:2011']">
<svrl:text>If the MPD is dynamic the Period element shall have an id.</svrl:text>
</svrl:failed-assert>
Schematron validation not successful – DASH is not valid!`

If I change <Period start="PT0.0S"> into <Period id="p0" start="PT0.0S"> it validates.
Seems like the id tag is necessary to keep the MPD valid for dynamic files.

Attachments (2)

test.mpd (1.9 KB ) - added by Ole Andre Birkedal 6 years ago.
DASH file
0001-Adding-id-attribute-to-Period-tag-of-DASH-manifest.-.patch (1.1 KB ) - added by Ole Andre Birkedal 6 years ago.
Patch to fix the Period tag

Download all attachments as: .zip

Change History (5)

by Ole Andre Birkedal, 6 years ago

Attachment: test.mpd added

DASH file

by Ole Andre Birkedal, 6 years ago

Patch to fix the Period tag

comment:1 by fiuqwb, 6 years ago

FYI http://dashif.org/conformance is the most up-to-date version of the DASH validator.

comment:2 by FishB8, 6 years ago

This would probably fix #4555

comment:3 by Carl Eugen Hoyos, 6 years ago

Resolution: duplicate
Status: newclosed

The patch was sent, this is apparently a duplicate of ticket #4555.
http://ffmpeg.org/pipermail/ffmpeg-devel/2016-May/194698.html

Note: See TracTickets for help on using tickets.