Opened 8 years ago

Closed 7 years ago

#524 closed enhancement (fixed)

AVC-Intra in mov not supported

Reported by: cehoyos Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: H264intra AVID AVin mov
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

http://www.datafilehost.com/download-733cd412.html
The file is supposed to be AVC-Intra, cannot be decoded with FFmpeg.

$ ffmpeg -i AVCI50.mov
ffmpeg version N-33192-gfe70c1f, Copyright (c) 2000-2011 the FFmpeg developers
  built on Oct  1 2011 12:36:37 with gcc 4.3.2 [gcc-4_3-branch revision 141291]
  configuration: --enable-libopenjpeg
  libavutil    51. 18. 0 / 51. 18. 0
  libavcodec   53. 19. 0 / 53. 19. 0
  libavformat  53. 13. 0 / 53. 13. 0
  libavdevice  53.  4. 0 / 53.  4. 0
  libavfilter   2. 43. 6 /  2. 43. 6
  libswscale    2.  1. 0 /  2.  1. 0

Seems stream 0 codec frame rate differs from container frame rate: 29970.00 (29970/1) -> 29.97 (2997/100)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'AVCI50.mov':
  Metadata:
    major_brand     : qt
    minor_version   : 537199360
    compatible_brands: qt
    creation_time   : 2011-09-29 14:51:08
  Duration: 00:00:18.01, start: 0.000000, bitrate: 57269 kb/s
    Stream #0:0(eng): Video: none (AVin / 0x6E695641), 1920x1080, 55731 kb/s, 29.97 fps, 29.97 tbr, 29970 tbn, 29970 tbc
    Metadata:
      creation_time   : 2011-09-29 14:51:08
    Stream #0:1(eng): Audio: pcm_s16be (twos / 0x736F7774), 48000 Hz, 2 channels, s16, 1536 kb/s
    Metadata:
      creation_time   : 2011-09-29 14:51:08
    Stream #0:2(eng): Data: none (tmcd / 0x64636D74)
    Metadata:
      creation_time   : 2011-09-29 14:51:14
At least one output file must be specified

Change History (6)

comment:1 Changed 8 years ago by cehoyos

  • Keywords H264 added
  • Status changed from new to open

comment:2 Changed 7 years ago by reimar

The file uses the AVin fourcc which seems to be a proprietary AVC-Intra format from Avid.
Do you have some tool that can losslessly convert this into more standard H.264/AVC-Intra?
It seems the PPS/SPS is missing, and guessing them doesn't seem realistic.
It would also already help if you can figure out whether the content is interlaced or not.
(since the timebase seems to be 1/30 interlaced should mean it is using MBAFF, which helps figuring out at least some SPS fields).

comment:3 Changed 7 years ago by cehoyos

  • Keywords AVID AVin added
  • Reproduced by developer set

Samples uploaded to samples.ffmpeg.org/ffmpeg-bugs/trac/ticket524

comment:4 Changed 7 years ago by cehoyos

  • Keywords H264intra added; H264 removed

Possibly related to tickets #1294 and #1666.

comment:5 Changed 7 years ago by cehoyos

  • Keywords mov added

comment:6 Changed 7 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Several samples have been fixed by a patch by Thomas Mundt and Reimar Döffinger.
I opened ticket #2106 for the remaining failing sample.

Note: See TracTickets for help on using tickets.