Opened 7 years ago

Closed 6 years ago

#1666 closed defect (fixed)

Unable to decode AVC-Intra file from Panasonic AG-HPX301E Camera

Reported by: rmk Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: ai12 h264intra mov
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

I have an AVC-Intra file from a professional Panasonic Camera (AG-HPX301E) that cannot be decoded by ffmpeg (I have tried transcoding also but output below makes it quite obvious that there's something wrong). The output looks as if the pixel format could not be determined.

Uncut command line and output below.

ffmpeg -i /Users/krueger/tmp/quarantene/0004WX.mov -probesize 50000000
ffmpeg version N-43678-gceb8773 Copyright (c) 2000-2012 the FFmpeg developers
  built on Aug 17 2012 22:28:27 with gcc 4.2.1 (GCC) (Apple Inc. build 5664)
  configuration: 
  libavutil      51. 70.100 / 51. 70.100
  libavcodec     54. 53.100 / 54. 53.100
  libavformat    54. 25.100 / 54. 25.100
  libavdevice    54.  2.100 / 54.  2.100
  libavfilter     3. 10.100 /  3. 10.100
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] non-existing PPS 0 referenced
[h264 @ 0x101009800] decode_slice_header error
[h264 @ 0x101009800] no frame!
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x10100f200] Stream #5: not enough frames to estimate rate; consider increasing probesize
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x10100f200] decoding for stream 0 failed
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x10100f200] Could not find codec parameters for stream 0 (Video: h264 (ai12 / 0x32316961), 1920x1080, 113664 kb/s): unspecified pixel format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Guessed Channel Layout for  Input Stream #0.1 : mono
Guessed Channel Layout for  Input Stream #0.2 : mono
Guessed Channel Layout for  Input Stream #0.3 : mono
Guessed Channel Layout for  Input Stream #0.4 : mono
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Users/krueger/tmp/quarantene/0004WX.mov':
  Metadata:
    major_brand     : qt  
    minor_version   : 537199360
    compatible_brands: qt  
    creation_time   : 2011-08-03 11:42:16
  Duration: 00:00:24.44, start: 0.000000, bitrate: 116839 kb/s
    Stream #0:0(eng): Video: h264 (ai12 / 0x32316961), 1920x1080, 113664 kb/s, SAR 1:1 DAR 16:9, 25 fps, 25 tbr, 2500 tbn, 5k tbc
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
      timecode        : 13:17:57:24
    Stream #0:1(eng): Audio: pcm_s16le (sowt / 0x74776F73), 48000 Hz, mono, s16, 768 kb/s
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
    Stream #0:2(eng): Audio: pcm_s16le (sowt / 0x74776F73), 48000 Hz, mono, s16, 768 kb/s
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
    Stream #0:3(eng): Audio: pcm_s16le (sowt / 0x74776F73), 48000 Hz, mono, s16, 768 kb/s
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
    Stream #0:4(eng): Audio: pcm_s16le (sowt / 0x74776F73), 48000 Hz, mono, s16, 768 kb/s
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
Codec 0x0 is not in the full list.
    Stream #0:5(eng): Data: unknown_codec (tmcd / 0x64636D74)
    Metadata:
      creation_time   : 2011-08-03 11:42:16
      handler_name    : Apple Alias-Datensteuerung
      timecode        : 13:17:57:24
At least one output file must be specified

The file can be downloaded at http://www.filehosting.org/file/details/368113/avc-intra-panasonic-AG-HPX301E.mov

Change History (6)

comment:1 Changed 7 years ago by rmk

Alternatively the file is now at: https://dl.dropbox.com/u/33388463/avc-intra-panasonic-AG-HPX301E.mov

Please, someone of the devs, move it somewhere else, because it will not stay there forever.

comment:2 Changed 7 years ago by cehoyos

  • Keywords ai12 added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Sample uploaded to samples/ffmpeg-bugs/trac/ticket1666, possibly related to #524.

comment:3 Changed 7 years ago by cehoyos

  • Description modified (diff)

comment:4 Changed 7 years ago by cehoyos

  • Keywords h264intra added

Maybe related to ticket #1294.

comment:5 Changed 7 years ago by cehoyos

  • Keywords mov added

comment:6 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by a patch from Thomas Mundt and Reimar Döffinger.

Note: See TracTickets for help on using tickets.