Opened 2 years ago

Last modified 15 months ago

#5141 reopened license violation

Eltima violates GPL

Reported by: llogan Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by llogan)

Elmedia Player contains ffmpeg binary. Configure includes license options --enable-gpl and --enable-version3.

http://mac.eltima.com/download/elmediaplayer.dmg

No source code available. No copy of license.

Change History (22)

comment:1 follow-up: Changed 2 years ago by annabrooks

Hello!

I am Anna Brooks from Eltima Software.

We use ffmpeg compiled binary downloaded from here: https://www.ffmpeg.org/download.html. Yes it was compiled with the flags, mentioned by you above.

As for no source code available. If you mean player source code, then according to http://www.gnu.org/licenses/gpl-faq.en.html#NFUseGPLPlugins we don't have to distribute it.
If you mean sources of ffmpeg we think that we don't have to open them too as we did not do any modifications of ffmpeg code. But if ffmpeg community insists, we can place the copy of current snapshot on our website. But we think that there is no need to do this. As guided by this (https://www.ffmpeg.org/legal.html) we should do this when linking against the FFmpeg libraries (we don't do this).

As for the license copy. We apologize that we did not do it earlier. That's our shortcoming and not a deliberate aim to violate the license. We'll fix this in the nearest future: we will add the license text to the internal package and mention in our EULA that we use FFmpeg under the GPLv3.

comment:2 in reply to: ↑ 1 Changed 2 years ago by Timothy_Gu

I am not a lawyer.

Replying to annabrooks:

As for no source code available. If you mean player source code, then according to ​http://www.gnu.org/licenses/gpl-faq.en.html#NFUseGPLPlugins we don't have to distribute it.

Is FFmpeg a plugin of Eltima Player? Or is it necessary for Eltima Player to function? If it is an essential part of Eltima Player, it cannot be considered to be a plugin.

Regardless, I believe that FFmpeg is an aggregate in this specific case: https://www.gnu.org/licenses/gpl-faq.html#MereAggregation, and thus the GPL does not apply to Eltima Player.

However, the GPL does apply to FFmpeg itself. And that's why you need to distribute the source code of FFmpeg in one of the fashions Section 6 of the GPLv3 describes: https://www.gnu.org/licenses/gpl-3.0.en.html#section6, in conjunction with the provisions of Section 4 since you said that no modifications were done to the FFmpeg source. You will need to check the individual libraries incorporated in the FFmpeg build as well for their license.

For the record, the elmediaplayer.dmg I have just downloaded on 2016-11-14 with SHA-256 hash bc7dd96f0094815c01435eada11e04c78031b0b114c27c3e63fa16f9b79d87ee contains a copy of ffmpeg executable with the following configuration:

--prefix=/Volumes/Ramdisk/sw --enable-gpl --enable-pthreads --enable-version3 --enable-libspeex --enable-libvpx --disable-decoder=libvpx --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libx264 --enable-avfilter --enable-libopencore_amrwb --enable-libopencore_amrnb --enable-filters --enable-libgsm --enable-libvidstab --enable-libx265 --arch=x86_64 --enable-runtime-cpudetect

At least vid.stab, x264, and x265 are distributed under the GPL (be sure to check the versions of the GPL also). At least libmp3lame is licensed under the LGPL. x265 especially ambiguous in its license version.

Note that even if Eltima Player is GPL you would still have to make available the source code. (That is why websites like Zeranoe which distribute FFmpeg in binary form distribute the corresponding source code as well.)

If you mean sources of ffmpeg we think that we don't have to open them too as we did not do any modifications of ffmpeg code. But if ffmpeg community insists, we can place the copy of current snapshot on our website. But we think that there is no need to do this. As guided by this (https://www.ffmpeg.org/legal.html) we should do this when linking against the FFmpeg libraries (we don't do this).

The legal guide is only that – a guide. The fact that it does not mention distributing as a separate program does not mean that there are no conditions for doing so.

As for the license copy. We apologize that we did not do it earlier. That's our shortcoming and not a deliberate aim to violate the license. We'll fix this in the nearest future: we will add the license text to the internal package and mention in our EULA that we use FFmpeg under the GPLv3.

Yes please. See Section 4 of GPLv3.

comment:3 Changed 2 years ago by annabrooks

Thanks for your comments. We will make necessary changes in the next release.

comment:4 Changed 21 months ago by annabrooks

  • Resolution set to fixed
  • Status changed from new to closed

In the latest release we have made all the necessary changes.

comment:5 Changed 21 months ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Please do not close license violation tickets, instead ask us to check again.

comment:6 Changed 21 months ago by cehoyos

  • Reproduced by developer set
  • Status changed from reopened to open

I downloaded http://mac.eltima.com/download/elmediaplayer.dmg (size 42197101, md5sum fee349fd909517248110b1feb588d232). The file contains a binary distribution of FFmpeg but not the appropriate license file.

comment:7 Changed 21 months ago by annabrooks

Please, check the following:
Elmedia Player contains two files: Elmedia Player.app/Contents/Resources/Licenses/Credits.txt and
Elmedia Player.app/Contents/Resources/Licenses/ffmpeg.txt. First file contains links on license text and sources, while second is an appropriate license file.

comment:8 follow-up: Changed 21 months ago by cehoyos

No.
(Please avoid making claims without double-checking yourself, this gives an overly bad impression of your company.)

More important though: How are your users supposed to know that your installer contains free software? You are speaking of an EULA above - where can I find it?

Finally: Where can the source code for all open source projects you distribute be found?

comment:9 in reply to: ↑ 8 Changed 21 months ago by heleppkes

Replying to cehoyos:

No.
(Please avoid making claims without double-checking yourself, this gives an overly bad impression of your company.)

Maybe you should take your own advice, because I can see those two files just fine.

comment:10 follow-up: Changed 21 months ago by cehoyos

And did you have a closer look at these files or do you think it is enough to create two files with specific names?

comment:11 Changed 21 months ago by gjdfgh

I agree. Why so obnoxious? The company is obviously complying sufficiently.

comment:12 in reply to: ↑ 10 Changed 21 months ago by heleppkes

Replying to cehoyos:

And did you have a closer look at these files or do you think it is enough to create two files with specific names?

They include the full license text as well as associating FFmpeg with it and linking back to our project page. Seems fine to me.

comment:13 Changed 21 months ago by annabrooks

You will find a notice about it on our user guide page: http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html

comment:14 Changed 21 months ago by llogan

  • Description modified (diff)

As Timothy_Gu mentioned, your ffmpeg binary uses --enable-gpl and --enable-version3, so you need to update Credits.txt, ffmpeg.txt, etc, to indicate usage of "GNU General Public License (GPL) version 3 or later" instead of LGPL 2.1.

Secondly, you need to be able to provide the source code of the exact version of ffmpeg that you used. You have multiple choices to satisfy this requirement, but I assume hosting the corresponding source code and making it simple for anyone to find will probably be easiest for you.

comment:15 Changed 21 months ago by annabrooks

In our latest version 6.5.2 we have made changes you asked about.

comment:16 Changed 21 months ago by cehoyos

Please allow me to repeat my questions:

  • How are users who download elmediaplayer.dmg from your download site supposed to know that the installer they downloaded contains free software that is licensed under the GPL?
  • You are speaking of an EULA above - where can I find it?
  • Where can the source code for all (other) open source projects you distribute as part of the installer be found?

comment:17 follow-up: Changed 21 months ago by annabrooks

1) Users can find the list of all third-party components and their licenses here http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html
2) You can find such information here: http://wiki.eltima.com/software-licenses/freeware-elmedia-full.html
3) We mentioned this in our previous messages? Did you check them?
http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html
Elmedia Player.app/Contents/Resources/Licenses/Credits.txt

comment:18 in reply to: ↑ 17 Changed 21 months ago by cehoyos

Replying to annabrooks:

1) Users can find the list of all third-party components and their licenses here http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html

And this page is linked from the EULA which makes sense (it could be part the EULA but it arguably does not have to be). But how are the users made aware of the EULA?

2) You can find such information here: http://wiki.eltima.com/software-licenses/freeware-elmedia-full.html

This contains the following text:

The Software contains components that were created by third parties and that are governed by the third-party licenses.

This is a definition that explains that the software you distribute contains parts that were not created by you but by third parties (which is correct and ok).

The Software as a whole is governed by EULA by Eltima Software (see above).

I don't think this is ok: FFmpeg is part of The Software but it is not governed by Eltima Software.

3) We mentioned this in our previous messages? Did you check them?

I am quite sure I checked them. (But see above about my real point.)

http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html

This site contains no link to the MPlayer sources you used.

Elmedia Player.app/Contents/Resources/Licenses/Credits.txt

Does this file really contain a link to the used MPlayer sources (and the other components)?

comment:19 Changed 21 months ago by llogan

  • Resolution set to fixed
  • Status changed from open to closed

I think this is now acceptable. The source code is now there, etc. The violations were due to a lack of understanding and they made an honest effort to comply.

MPlayer issues should be limited to MPlayer tracker.

comment:20 Changed 21 months ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

MPlayer still contains a lot of FFmpeg source code...

comment:21 Changed 15 months ago by annabrooks

We hosted ffmpeg and mplayer on our server and listed the download links to them in the user guide, which is publicly available on our website: http://wiki.eltima.com/user-guides/elmedia-mac/third-party-libs.html.

We also linked to this page in the About dialog of the software.

comment:22 Changed 15 months ago by cehoyos

Where can I find the current installer?

Note: See TracTickets for help on using tickets.