Opened 3 years ago

Closed 3 years ago

#5142 closed defect (fixed)

(serious issue) -coder option does not work anymore with the latest GIT

Reported by: Atarikid Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: libx264 regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

With the latest GIT the option -coder does not work anymore.

Last login: Sat Jan 9 10:47:44 on ttys001
atarikid-MacBook?-Pro:~ atarikid$ /Users/atarikid/Desktop/ffmpeg2 -i /Users/atarikid/Desktop/Rock.mp4 -coder ac /Users/atarikid/Desktop/Rock1.mp4
ffmpeg version N-77737-gb0e23f2-tessus Copyright (c) 2000-2015 the FFmpeg developers

built with Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn)
configuration: --cc=/usr/bin/clang --prefix=/opt/ffmpeg --as=yasm --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzmq --enable-version3 --disable-ffplay --disable-indev=qtkit --disable-indev=x11grab_xcb
libavutil 55. 11.100 / 55. 11.100
libavcodec 57. 20.100 / 57. 20.100
libavformat 57. 21.100 / 57. 21.100
libavdevice 57. 0.100 / 57. 0.100
libavfilter 6. 22.100 / 6. 22.100
libswscale 4. 0.100 / 4. 0.100
libswresample 2. 0.101 / 2. 0.101
libpostproc 54. 0.100 / 54. 0.100

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/Users/atarikid/Desktop/Rock.mp4':

Metadata:

major_brand : mp42
minor_version : 0
compatible_brands: isomavc1mp42
creation_time : 2010-07-13 15:38:07

Duration: 00:03:48.08, start: 0.000000, bitrate: 565 kb/s

Stream #0:0(und): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 93 kb/s (default)
Metadata:

creation_time : 2010-07-13 15:38:07
handler_name : (C) 2007 Google Inc. v08.13.2007.

Stream #0:1(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 480x270 [SAR 1:1 DAR 16:9], 469 kb/s, 25 fps, 25 tbr, 25k tbn, 50 tbc (default)
Metadata:

creation_time : 2010-07-13 15:38:07
handler_name : (C) 2007 Google Inc. v08.13.2007.

File '/Users/atarikid/Desktop/Rock1.mp4' already exists. Overwrite ? [y/N] y
[libx264 @ 0x7fb4e3007600] [Eval @ 0x7fff5648b4e0] Undefined constant or missing '(' in 'ac'
[libx264 @ 0x7fb4e3007600] Unable to parse option value "ac"
[libx264 @ 0x7fb4e3007600] Error setting option coder to value ac.
Output #0, mp4, to '/Users/xtophe/Desktop/Rock1.mp4':

Metadata:

major_brand : mp42
minor_version : 0
compatible_brands: isomavc1mp42
Stream #0:0(und): Video: h264, none, q=2-31, 128 kb/s, SAR 1:1 DAR 0:0, 25 fps (default)
Metadata:

creation_time : 2010-07-13 15:38:07
handler_name : (C) 2007 Google Inc. v08.13.2007.
encoder : Lavc57.20.100 libx264

Stream #0:1(und): Audio: aac, 0 channels, 128 kb/s (default)
Metadata:

creation_time : 2010-07-13 15:38:07
handler_name : (C) 2007 Google Inc. v08.13.2007.
encoder : Lavc57.20.100 aac

Stream mapping:

Stream #0:1 -> #0:0 (h264 (native) -> h264 (libx264))
Stream #0:0 -> #0:1 (aac (native) -> aac (native))

Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
atarikid-MacBook?-Pro:~ atarikid $

Tried with both numbers or letters (-coder 2 , -coder ac) ...

Works fine with the latest point release 2.8.4

Change History (7)

comment:1 Changed 3 years ago by Atarikid

Forgotten to add:
Happens with both Windows and OSX builds.

comment:2 Changed 3 years ago by heleppkes

You should be able to use "-coder cabac" now, seems to be an oversight to stop supporting the old name.

Last edited 3 years ago by heleppkes (previous) (diff)

comment:3 Changed 3 years ago by Atarikid

What to use for vlc, raw, rle, deflate? Those aren't working too.

Will this be fixed in the next GIT release?

comment:4 Changed 3 years ago by heleppkes

The x264 encoder only supports two coders, cabac and cavlc, rle and deflate never did anything.

comment:5 Changed 3 years ago by Atarikid

OK, but using cabac or cavlc will introduce backwards incompatibility. for example 2.8.4 does not recognise those.

So the question remains: will it be fixed in the next GIT? :-)

comment:6 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords libx264 regression added
  • Priority changed from critical to important
  • Status changed from new to open

Regression since 2630f7f709049113dc03d6b999efad6acc423d67, patch sent.

comment:7 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Compatibility options added in f587ed0cbbda2de85d0fb34a4fdca89ccb1f1e61

Note: See TracTickets for help on using tickets.