Opened 9 years ago

Last modified 9 years ago

#1800 reopened enhancement

support iTunes drm encrypted files

Reported by: Raffaele Mancuso Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords: drm
Cc: onemda@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have downloaded a video from itunes. The video has .m4v extension and according to MediaVideo is in some type of AVC/AAC format. Nor VLC neither Windows Media PLayer can play that video. The only one that can play the video and do it correctly is QuickTime 7 from Apple.

I want to convert it into MPEG2 as video and mp3 as audio, but i have failed both with FFMPEG and with MEncoder. I have also tried to compile ffmpeg from source, but I do not know which codec I need and I don't want to compile all the codecs from scratch.

I have uploaded the video on your FTP server. THe filename is "Love Thy Brother.m4v". There IS the correspondending text file.

I attach here:
1) Mediainfo informations given on the video
2) ffmpeg command line
3) full FFMPEG console output

Attachments (5)

FFMPEG_Command_Line.txt (150 bytes ) - added by Raffaele Mancuso 9 years ago.
MediaInfo.txt (6.5 KB ) - added by Raffaele Mancuso 9 years ago.
FFMPEG_output_1.txt (717.9 KB ) - added by Raffaele Mancuso 9 years ago.
First part of the output, split in multiple files due to the 2.5M file size restriction
FFMPEG_output_2.txt (1.8 MB ) - added by Raffaele Mancuso 9 years ago.
FFMPEG_output_3.log (898.0 KB ) - added by Raffaele Mancuso 9 years ago.

Change History (12)

by Raffaele Mancuso, 9 years ago

Attachment: FFMPEG_Command_Line.txt added

by Raffaele Mancuso, 9 years ago

Attachment: MediaInfo.txt added

by Raffaele Mancuso, 9 years ago

Attachment: FFMPEG_output_1.txt added

First part of the output, split in multiple files due to the 2.5M file size restriction

by Raffaele Mancuso, 9 years ago

Attachment: FFMPEG_output_2.txt added

by Raffaele Mancuso, 9 years ago

Attachment: FFMPEG_output_3.log added

comment:1 by Carl Eugen Hoyos, 9 years ago

Resolution: invalid
Status: newclosed

I think it is unlikely that FFmpeg can play anything called "drmi" or "drms".

For future tickets:
I do not remember a report where MediaInfo output was useful, the output of ffmpeg -i yourfile is always needed, so it makes reading the ticket much easier if you simply post the ffmpeg -i yourfile command line together with the complete, uncut console output into the ticket.

comment:2 by Carl Eugen Hoyos, 9 years ago

Are you in any way related to MediaCoder?
Or are you just a user?

Note that Stanley Huang, the distributor of MediaCoder, is known for a long time as a copyright violator here (he violates the copyrights of FFmpeg and MPlayer authors for several years), so FFmpeg developers are not close friends of the application.

comment:3 by Raffaele Mancuso, 9 years ago

I think that all your attitude with your users are just rude. First someone here (http://ffmpeg.gusari.org/viewtopic.php?f=11&t=695) told me all the operations to do to report that, including uploading the video to your FTP server and find by myself a solution to post the full FFMPEG console output despite your characters per post restriction and your maximum file size restriction in this size. If your software have an output that overcome the restriction and you request that output, why you put the restriction at all in the first place? Now you just close it with a "there is a drmi in the MediaInfo report", making vain all the time I spent on it.

I do not know why if QuickTime is able to play it we (you) cannot even think to implement a decoder for that format (as you have put the question, it is not a matter of time for you but a matter of the drmi string)

Now the MediaCoder think. If someone violated your copyright, legal prosecute him. If you don't, you just don't accuse a user that report a bug to your software of "relation with whom has violated your copyright". BTW, if that makes you sleep better, I have misplelled MediaInfo with MediaCoder because yes, I have MediaCoder installed. I got aware of that "bug" in FFMPEG because MediaCoder was not able to convert that video.

comment:4 by Elon Musk, 9 years ago

Cc: onemda@gmail.com added
Priority: normalwish
Resolution: invalid
Status: closedreopened
Type: defectenhancement
Version: unspecifiedgit-master

Please provide link to such file.

comment:5 by burek, 9 years ago

@cehoyos
Please stop your practice of closing bug reports on the first reply or otherwise closing them too easily. It really makes people pissed, since they invested THEIR time and will to provide US with a bug report, that WE need. So, please at least pay a little bit more respect to those people, otherwise, in the future, nobody else will care to report anything to ffmpeg any more.

@raffairon
Sorry about this. This ticket should stay open until it is discarded as "won't fix" or until the feature is implemented properly.
This is definitely a bug, since if ffmpeg doesn't support >>anything called "drmi" or "drms"<< it should clearly show the error/warning message and quit instead of users having to guess what on earth has happened.

in reply to:  4 comment:6 by Raffaele Mancuso, 9 years ago

Replying to richardpl:

Please provide link to such file.

as said, I have uploaded the video on your FTP server, in the incoming folder. The filename is "Love Thy Brother.m4v". There is the correspondending text file, with a link to the original discussion on the forum

comment:7 by compn, 9 years ago

Keywords: drm added
Summary: video downloaded from iTunes do not worksupport iTunes drm encrypted files

like carl says, this file (along with lots of others from itunes) is drm encrypted.
ffmpeg does not support drm encrypted itunes files.

if you wish to convert it, you can use requiem program to remove the drm from the file first.

some info:
http://undrm.info/remove-DRM-protection/Requiem-freeware-Mac-and-PC-DRM-remover-for-iTunes-files.htm

the requiem website is hosted on tor. kind of hard to access it.

Note: See TracTickets for help on using tickets.