Opened 2 weeks ago

Closed 2 weeks ago

#7135 closed defect (invalid)

Cannot compile x264 on Ubuntu 17.10 (Artful) according to UbuntuCompileGuide

Reported by: sroller Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm trying to compile ffmpeg from git sources on Ubuntu 17.10 (Artful).
I followed the guide from https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

It fails linking x264. The results can be seen here https://pastebin.com/MLJTJmXK

I have an open question on https://superuser.com/questions/1312329/compiling-latest-version-of-libx264-for-ffmpeg-fails-on-ubuntu-17-10-artful

I set up a pristine machine via Droplet at Digitalocean. The same error occurs there.

Change History (4)

comment:1 Changed 2 weeks ago by sroller

I forget to add that I was successful after I manually ran configure --enable-shared. I had to install libx264.so manually as well after that change.

comment:2 Changed 2 weeks ago by llogan

  • Component changed from ffmpeg to wiki
  • Keywords x264 removed
  • Priority changed from normal to wish
  • Type changed from defect to enhancement
  • Version changed from git-master to unspecified

Not a FFmpeg bug. Ubuntu 16.10 and newer have enabled PIE in GCC. You don't need --enable-shared. Try --enable-pic instead.

Please note that this is only a bug tracker, so if you need additional help see the ffmpeg-user mailing list.

comment:3 Changed 2 weeks ago by sroller

  • Component changed from wiki to ffmpeg
  • Keywords x264 added
  • Priority changed from wish to normal
  • Type changed from enhancement to defect
  • Version changed from unspecified to git-master

Turns out that a hardening measure on gcc caused the problem.
One has to run configure --enable-pic. The CompilationGuide should be changed.

comment:4 Changed 2 weeks ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords x264 removed
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.