Opened 19 months ago

Last modified 4 weeks ago

#9950 reopened enhancement

No docs for paletteuse filter option "dither=none"

Reported by: jason Owned by:
Priority: minor Component: documentation
Version: unspecified Keywords: filters
Cc: jason, MasterQuestionable Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The docs for paletteuse list "bayer", "heckbert", "floyd_steinberg", "sierra2", and "sierra2_4a" as acceptable values for "dither", with no documented option for disabling dithering entirely.

However, the filter appears to accept "none" as an option to disable dithering, at least in:

  • Whatever version the author of this answer was using in Nov 2020, as well as the author of the question there, and
  • My version: 4.3.2-2021-02-27-full_build-www.gyan.dev (I didn't test on others).

It should probably be documented. However, I'm not sure if this is a documentation error vs. "none" not being a stable long-term option.

Does anybody know what version "dither=none" started being valid with, and whether or not it's intended to continue working in the foreseeable future? If it's an unstable or temporary feature, then it might not actually be a documentation error.

Change History (4)

comment:1 by jason, 19 months ago

Note: http://blog.pkh.me/p/21-high-quality-gif-with-ffmpeg.html (dated 2015) mentions the option:

Of course, you can also completely disable the dithering by using dither=none.

comment:2 by Stefano Sabatini, 13 months ago

Resolution: fixed
Status: newclosed

Should be fixed in 0684e588868, thanks for the report!

comment:3 by MasterQuestionable, 4 weeks ago

Priority: normalminor
Resolution: fixed
Status: closedreopened
Type: defectenhancement

ffmpeg -hide_banner -h filter=paletteuse?

comment:4 by MasterQuestionable, 4 weeks ago

Cc: MasterQuestionable added
Note: See TracTickets for help on using tickets.