Opened 5 years ago

Closed 5 years ago

#957 closed defect (fixed)

can't decode MJPEG avi

Reported by: swybo Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: mjpeg avi
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no


Trying to decode video encoded with MJPEG codec will fail if video contains delta frames => only first image will be decoded

reproduced with ffmpeg, ffplay

Windows 7 64bits, ffmpeg 0.10

Attachments (1)

ffmpeg-20120130-122028.log (6.7 KB) - added by swybo 5 years ago.
output report

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords mjpeg added
  • Priority changed from important to normal

To make this a valid ticket, please add

  • a failing ffmpeg command line together with
  • complete, uncut console output and
  • a sample

Changed 5 years ago by swybo

output report

comment:2 Changed 5 years ago by swybo

Sorry about that...
Complete command line that generated the report file:

ffmpeg -v 9 -loglevel 99 -i MJPEGVideoWithDFrames.avi output.avi -report

Last edited 5 years ago by swybo (previous) (diff)

comment:3 Changed 5 years ago by swybo

Sample video file is currently uploaded to

comment:4 Changed 5 years ago by reimar

This has nothing to do with "delta frames" (no idea what it is but I don't think it is even used here) and nothing with the (M)JPEG decoder.
MPlayer can play it fine using FFmpeg's decoder.
It plays only one frame when using -demuxer lavf though.
ffprobe -show_packets confirms FFmpeg sees only a single video frame.
This should be a bug in the AVI demuxer.

comment:5 Changed 5 years ago by swybo

That's my point actually, if you check the avi file in virtual dub you'll see D frames (delta frames) every 3 frames with no data in it. This is caused by a badly functionning encoder actually but VLC or virtual dub can read all frames in the video whereas ffplay, ffmpeg... can't find any frame other than the first one

I thought this indicated some kind of issue in the AVI demuxer

comment:6 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from 0.10 to git-master

comment:7 Changed 5 years ago by cehoyos

  • Summary changed from can't decode MJPEG video with delta frames to can't decode MJPEG avi

comment:8 Changed 5 years ago by cehoyos

  • Keywords avi added

comment:9 Changed 5 years ago by reimar

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.