Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#9450 closed defect (fixed)

Error in double-fisheye to equirectangular conversion

Reported by: Michael Koch Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

There is a rounding or +-1 error in the double-fisheye to equirectangular conversion. Can be reproduced as follows:

ffmpeg -f lavfi -i color=red:s=20x20 -f lavfi -i color=green:s=20x20 -lavfi hstack,v360=dfisheye:e -frames 1 -y out.png

Change History (5)

comment:1 by Michael Koch, 8 months ago

Summary: Error in double-fisheye to equirecatngular conversionError in double-fisheye to equirectangular conversion

comment:2 by Michael Koch, 8 months ago

Another problem is that the pixels in the output image appear twice as big as they should be. What looks like one pixel is in fact 2x2 pixels.

comment:3 by Michael Koch, 8 months ago

Same problem also when converting from equirectangular to double-fisheye. The pixels are twice as big as they should be.

ffmpeg -f lavfi -i color=red:s=10x20 -f lavfi -i color=green:s=20x20 -lavfi [0]split[a][b];[a][1]hstack[a];[a][b]hstack,v360=e:dfisheye -frames 1 -y out.png

comment:4 by Elon Musk, 8 months ago

Resolution: invalid
Status: newclosed

used subsampled inputs.

comment:5 by Michael Koch, 8 months ago

Resolution: invalidfixed

The first problem was fixed here

http://ffmpeg.org/pipermail/ffmpeg-cvslog/2021-October/129405.html

and here

http://ffmpeg.org/pipermail/ffmpeg-cvslog/2021-October/129406.html

Thank you!

The second problem was my fault, because the input was subsampled.

Note: See TracTickets for help on using tickets.