Opened 18 months ago

Closed 16 months ago

Last modified 16 months ago

#9355 closed defect (fixed)

Fix for PES packets with too much padding

Reported by: Sergio Ammirata, Ph.D. Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
PES packet with too much padding trigger unlimited error messages "PES packet size mismatch" because the code that corrects the length is wrong.
Here is a sample file: http://99.93.62.129/smpte2038.ts
PID 300 is the one triggering the errors.
I am attaching a patch that fixes the problem.

Attachments (1)

0001-Fix-setting-the-correct-size-for-PES-packets-with-to.patch (1011 bytes ) - added by Sergio Ammirata, Ph.D. 18 months ago.
proposed patch

Download all attachments as: .zip

Change History (11)

by Sergio Ammirata, Ph.D., 18 months ago

proposed patch

comment:1 by Balling, 18 months ago

What is #2392? That one has nothing to do with above.

in reply to:  1 ; comment:2 by Sergio Ammirata, Ph.D., 18 months ago

Replying to Balling:

What is #2392? That one has nothing to do with above.

I do not know what #2392 is ... that comment was there from before.

in reply to:  2 comment:3 by Balling, 18 months ago

Replying to Sergio Ammirata, Ph.D.:

Replying to Balling:

What is #2392? That one has nothing to do with above.

I do not know what #2392 is ... that comment was there from before.

Yet that comment should be deleted after your change or better clarified. Also, there are other bugs that often have this PES warning, maybe they should be checked too.

Last edited 18 months ago by Balling (previous) (diff)

comment:4 by Balling, 18 months ago

For example, does it fix that warning sample in #3309? What about my issue #8108? Also samples in #6152. And in #6026.

Last edited 18 months ago by Balling (previous) (diff)

comment:5 by Balling, 18 months ago

Status: newopen

Also this is a duplicate of #5860. P.S. Apparently not.

Last edited 16 months ago by Balling (previous) (diff)

in reply to:  2 comment:6 by Balling, 18 months ago

Replying to Sergio Ammirata, Ph.D.:

Replying to Balling:

What is #2392? That one has nothing to do with above.

I do not know what #2392 is ... that comment was there from before.

I found it! It is this issue, https://ffmpeg-issues.lscube.narkive.com/s0jecfqy/issue2392-memory-leak-in-mpegts-demuxer-on-samples-with-too-large-pes-packets so a different bug tracker. WTF.

Last edited 18 months ago by Balling (previous) (diff)

comment:7 by Balling, 17 months ago

What is even in that PID 0x012c in PES data?

comment:9 by Marton Balint, 16 months ago

Resolution: fixed
Status: openclosed

comment:10 by Balling, 16 months ago

Yet it does not fix any other issues above, interesting!

Note: See TracTickets for help on using tickets.