Opened 5 years ago

Closed 3 weeks ago

#5860 closed defect (fixed)

"Could not find codec parameters for stream 0" for TS stream that mplayer can play

Reported by: Jonathan Kamens Owned by:
Priority: important Component: avformat
Version: git-master Keywords: probe regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I am trying to convert a ts stream produced by my TV tuner into an MP4 file:

ffmpeg -i sample-video.ts sample-video.mp4

It is reporting "PES packet size mismatch" and "Could not find codec parameters for stream 0 (Unknown: none): unknown codec Consider increasing the value for the 'analyzeduration' and 'probesize' options".

The video plays fine with mplayer and encodes fine with mencoder.

Other videos recorded from the tuner do not have this problem.

This discussion -- http://ffmpeg.gusari.org/viewtopic.php?f=11&t=853 -- suggests that it is appropriate for me to report this problem to you because you may be able to debug it and improve ffmpeg to make it go away in the future.

Attachments (2)

ffmpeg-output (15.6 KB ) - added by Jonathan Kamens 5 years ago.
Output of "ffmpeg -v 9 -loglevel 99 -i sample-video.ts sample-video.mp4"
ffmpeg-20160923-085248.log (9.3 KB ) - added by Jonathan Kamens 5 years ago.
Log file created by "ffmpeg -report -v 9 -loglevel 99 -i sample-video.ts sample-video.mp4"

Download all attachments as: .zip

Change History (10)

by Jonathan Kamens, 5 years ago

Attachment: ffmpeg-output added

Output of "ffmpeg -v 9 -loglevel 99 -i sample-video.ts sample-video.mp4"

by Jonathan Kamens, 5 years ago

Attachment: ffmpeg-20160923-085248.log added

Log file created by "ffmpeg -report -v 9 -loglevel 99 -i sample-video.ts sample-video.mp4"

comment:1 by Jonathan Kamens, 5 years ago

I have a 4MB file file which demonstrates this issue. I am unable to FTP it to upload.ffmpeg.org:

$ ncftp upload.ffmpeg.org
NcFTP 3.2.5 (Feb 02, 2011) by Mike Gleason (http://www.NcFTP.com/contact/).
Could not connect to 138.195.131.196: No route to host.
Could not open host upload.ffmpeg.org: could not connect to remote host.

You can download it from my NAS:

http://gofile.me/2J75a/xUY7VIJE9

If/when upload.ffmpeg.org is fixed and you would like me to upload the file there, please let me know. Or if there is some other way to get it to you, please let me know that.

comment:2 by Carl Eugen Hoyos, 5 years ago

Component: undeterminedavformat
Keywords: probe regression added
Priority: normalimportant
Reproduced by developer: set
Status: newopen
Version: unspecifiedgit-master

Regression since 15957b19, related to issue 2312.
Originally fixed in af122d6a.

comment:3 by Jonathan Kamens, 4 years ago

Do you need the sample video I mentioned above? If so, have you downloaded it? I would like to delete it from my NAS.

comment:4 by Hendrik, 4 years ago

The file is available from our issue sample server (http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket5860/sample-video.ts), you can delete it.

comment:5 by Balling, 2 months ago

Last edited 5 weeks ago by Balling (previous) (diff)

comment:6 by Balling, 4 weeks ago

Apparently the problem is that probesize was not applied here and always defaulted to 2500k: https://patchwork.ffmpeg.org/project/ffmpeg/patch/20211107173810.31787-1-cus@passwd.hu/

Last edited 3 weeks ago by Balling (previous) (diff)

comment:7 by Balling, 3 weeks ago

With 406ffd9b9b99fa096bcfe31b467453824d1542e7 you can now ffplay the file without any additional options, et cetera, yet does not fix the warning. On the commit using -probesise 250000 will break it again and 300000 will fix it, yet the last one does not play any role in older commits, so nice fix indeed. Hmmm.

Last edited 3 weeks ago by Balling (previous) (diff)

comment:8 by Marton Balint, 3 weeks ago

Resolution: fixed
Status: openclosed
Summary: "PES packet size mismatch", "Could not find codec parameters for stream 0" for TS stream that mplayer can play"Could not find codec parameters for stream 0" for TS stream that mplayer can play

Fixed in 406ffd9b9b99fa096bcfe31b467453824d1542e7.

The PES packet size mismatch message was always misleading in this report, because that was not the root cause of the issue.

Note: See TracTickets for help on using tickets.