Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#9310 closed defect (wontfix)

ffmpeg configure ignores CC and CXX environment variables

Reported by: Simon Toth Owned by:
Priority: normal Component: build system
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

Run:
CC=clang CXX=clang++ ./configure

Configure script reports:
C Compiler gcc

This is a blocker for compiling ffmpeg inside sandboxes (such as part of Bazel) where the path to the compiler is injected by the runtime.

Change History (4)

comment:1 by Carl Eugen Hoyos, 12 months ago

Resolution: wontfix
Status: newclosed

This is the intended and documented behaviour, use --cc (there should be no c++ compiler needed to build FFmpeg).

comment:2 by Simon Toth, 12 months ago

Could you provide more details why this is the intended behaviour? I was planning to send a patch.

Using --cc obviously isn't possible if you don't know the compiler path upfront, which is the case with many sandboxes.

Also, my sampling could totally be biased, but I would think that following CC is the normal behaviour for a configure script. At least I don't remember any other instance of this problem.

comment:3 by Carl Eugen Hoyos, 12 months ago

FFmpeg's configure script is not autoconf-based and therefore does not necessarily copy its behaviour.

comment:4 by Simon Toth, 12 months ago

Following CC is standard behaviour even for pure Makefile projects, so not sure what this has to do with autoconf.

But I see that should just leave this be, so I will take my time and effort elsewhere. Thanks for the responses.

Note: See TracTickets for help on using tickets.