Opened 14 months ago

Last modified 14 months ago

#9200 reopened defect

drawtext issue when apply hindi language font file or other language font file

Reported by: jaydip nathani Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by jaydip nathani)

We are trying to use ffmpeg drawtext to support hindi fonts. but some characters are not rendering properly.

Used Hindi Language Font file :-https://fonts.google.com/specimen/Khula

ffmpeg -i myvideo.mp4 -i image.png -filter_complex [0:v][1:v]overlay=5:5,drawtext=textfile=hindi.txt:fontfile=Khula-Regular.ttf:fontsize=30:x=30:y=200 -c:a copy output.mp4

Input string :- जिन्दगी सिर्फ हकीक़त है हकीक़त समझो,

But output renders as
https://drive.google.com/file/d/1ZjZQB4Hq0Xxfrjjp1EC60e3tHhmw353X/view

Attachments (3)

hindi.txt (93 bytes ) - added by jaydip nathani 14 months ago.
Hindi Input text file
Khula-Regular.ttf (147.7 KB ) - added by jaydip nathani 14 months ago.
Hindi Language Font file
ouput_hindi.PNG (236.4 KB ) - added by jaydip nathani 14 months ago.
Output of code

Download all attachments as: .zip

Change History (16)

comment:1 by Carl Eugen Hoyos, 14 months ago

Component: ffmpegundetermined
Description: modified (diff)
Priority: criticalnormal

comment:2 by Balling, 14 months ago

Is this due to ligartures in Hindi? Also, Notepad++ does not use DirectWrite on your screenshot?

in reply to:  2 ; comment:3 by jaydip nathani, 14 months ago

Replying to Balling:

Yes this due to ligatures in Hindi.

Last edited 14 months ago by jaydip nathani (previous) (diff)

in reply to:  3 comment:4 by jaydip nathani, 14 months ago

when get from .txt file it that issue ?

Last edited 14 months ago by jaydip nathani (previous) (diff)

comment:5 by Carl Eugen Hoyos, 14 months ago

Resolution: duplicate
Status: newclosed

Feel free to attach hindi.txt and reopen this ticket if it is neither a duplicate of ticket #8738 nor #3165.

in reply to:  5 comment:6 by jaydip nathani, 14 months ago

Resolution: duplicate
Status: closedreopened

Replying to Carl Eugen Hoyos:

We do not use subtitles filter , use drawtext

comment:7 by jaydip nathani, 14 months ago

Resolution: invalid
Status: reopenedclosed

comment:8 by jaydip nathani, 14 months ago

Resolution: invalid
Status: closedreopened

comment:9 by jaydip nathani, 14 months ago

Priority: normalcritical

comment:10 by Carl Eugen Hoyos, 14 months ago

Priority: criticalnormal

comment:11 by Carl Eugen Hoyos, 14 months ago

Please don’t forget to attach hindi.txt

by jaydip nathani, 14 months ago

Attachment: hindi.txt added

Hindi Input text file

by jaydip nathani, 14 months ago

Attachment: Khula-Regular.ttf added

Hindi Language Font file

comment:12 by jaydip nathani, 14 months ago

Description: modified (diff)

by jaydip nathani, 14 months ago

Attachment: ouput_hindi.PNG added

Output of code

comment:13 by jaydip nathani, 14 months ago

Description: modified (diff)
Note: See TracTickets for help on using tickets.