Opened 7 years ago

Closed 6 years ago

#919 closed defect (fixed)

Embedded mkv subtitles are staying longer than they are supposed to be in converted file

Reported by: KuroiTsuki Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Actually summary says sums it's up

Change History (7)

comment:1 Changed 7 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 7 years ago by cehoyos

I have been asked for clarification why I closed this ticket as invalid.

The relevant page that explains how and where bugreports should be made (and I believe everybody can easily see that we like bugreports - just scan through the last six months of activity on this tracker) is http://ffmpeg.org/bugreports.html
Several points are mentioned there that are necessary for a valid (and useful) bugreport.
(If somebody sent you directly to this bugtracker instead of mentioned page, the following is of course his fault, all users that would like to report a problem should be sent to above website.)

Typically (and I guess this is such a typical issue), three things are necessary for each bugreport: A ffmpeg command line (no external libraries like x264 and faac if not needed to reproduce the bug, as short as possible command line) possibly with a short explanation what is expected, the complete, uncut console output that the command line produced together with an explanation what is wrong with the output file (that is the only thing provided here afaict). The third thing is a sample, I believe it is obvious that it actually is needed in this case. I suspect that your sample should be longer than 10MB, that is no problem, the upload directory accepts longer files, as an alternative, use http://www.datafilehost.com/ which accepts up to 100MB.

If one of mentioned things is missing (like the sample or the complete, uncut console output), we will usually simply ask for the missing information. If all necessary information is missing, I often close the report like in this case, but please reopen the ticket if you can provide the missing information.

comment:3 Changed 7 years ago by KuroiTsuki

  • Resolution invalid deleted
  • Status changed from closed to reopened

I have to agree, previous report was pretty much not informative and useless. Let me try again.

This is sample source file i used for conversion (but it is same with any mkv with embedded subtitles)
http://www.mediafire.com/?i3ezh3x35bk6f46
This is result of conversion, you can notice subtitles are staying for longer than they are supposed too
http://www.mediafire.com/?cnk3m9zn5ceekoo
This is file showing how it is supposed to be
http://www.mediafire.com/?dwstf0mrbk8a733
This is command line
http://pastebin.com/PPW74uLH
Note. I'm using mencoder, but people from mplayer/mencoder team said this is bug in ffmpeg, so now i'm reporting it here
If you need anymore information, I will gladly provide it
And thank you for your hard work

comment:4 Changed 7 years ago by reimar

My fault, I am not sure this can be reproduced with FFmpeg.
The problem (as I remember it) is that the end_pts/duration of the subtitle is no longer exported while the replacement for that feature, a proper ASS -> plain sub converter was never finished.
That leaves MPlayer without a solution except having to painfully parse the code back into exactly the format as it was in the MKV file after FFmpeg clobbered it back to the "standard" format.

comment:5 Changed 7 years ago by KuroiTsuki

so, what can I expect? What is solution for me?

comment:6 Changed 7 years ago by cehoyos

If you need help, you will have to provide an FFmpeg command line, this is not MEncoder-help (in case Reimar did not clearly say so: Please note that MEncoder is not an actively maintained application).
Did you try if the harddup filter works in FFmpeg?

Since it seems I forgot to mention above:
Except for large sample files, please do not save any information needed to reproduce your issues on other websites, always post all information here! The reason is that external information might disappear.

comment:7 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from reopened to closed

The problem that the subtitles stay on screen too long is not reproducible with MEncoder anymore, works fine with ffplay -vf subtitles and ffmpeg -vf subtitles.

Note: See TracTickets for help on using tickets.