#8676 closed defect (duplicate)

Concat demuxer prefixing the first input file path with "i"

Reported by: Kuba Orlik Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: liuqi05@kuaishou.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

I was trying to create a simple slideshow with the concat demuxer. I've created an input.txt file. The first file in the input file was named "a.png". Fffmpeg threw an error saying "[concat @ 0x55e0599ec6c0] Impossible to open 'ia.png'". I've checked twice and there's no "ia.png" in the input.txt file. Renaming the a.png file to ia.png solves this issue.

This bug seems to apply only to the first file in the input.txt.

How to reproduce:

% cat input.txt
ffconcat version 1.0
file a.png
duration 10
file b.png
duration 10
file b.png

% ffmpeg -f concat -i input.txt output.mp4
ffmpeg version git-2020-05-16-1ead7ed Copyright (c) 2000-2020 the FFmpeg developers
  built with gcc 9.3.0 (Arch Linux 9.3.0-1)
  configuration: 
  libavutil      56. 45.100 / 56. 45.100
  libavcodec     58. 84.100 / 58. 84.100
  libavformat    58. 43.100 / 58. 43.100
  libavdevice    58.  9.103 / 58.  9.103
  libavfilter     7. 81.100 /  7. 81.100
  libswscale      5.  6.101 /  5.  6.101
  libswresample   3.  6.100 /  3.  6.100
[concat @ 0x55d48fb866c0] Impossible to open 'ia.png'
input.txt: No such file or directory

{{{{
% ffmpeg -v 9 -loglevel 99 -i input.txt
ffmpeg version git-2020-05-16-1ead7ed Copyright (c) 2000-2020 the FFmpeg developers

built with gcc 9.3.0 (Arch Linux 9.3.0-1)
configuration:
libavutil 56. 45.100 / 56. 45.100
libavcodec 58. 84.100 / 58. 84.100
libavformat 58. 43.100 / 58. 43.100
libavdevice 58. 9.103 / 58. 9.103
libavfilter 7. 81.100 / 7. 81.100
libswscale 5. 6.101 / 5. 6.101
libswresample 3. 6.100 / 3. 6.100

Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ... matched as input url with argument 'input.txt'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Successfully parsed a group of options.
Parsing a group of options: input url input.txt.
Successfully parsed a group of options.
Opening an input file: input.txt.
[NULL @ 0x55c35d7745c0] Opening 'input.txt' for reading
[file @ 0x55c35d775100] Setting default whitelist 'file,crypto,data'
[AVIOContext @ 0x55c35d77d4c0] Statistics: 57 bytes read, 0 seeks
input.txt: Invalid data found when processing input
}}}}

I ran git bisect and found that the first commit to have this behavior is 648051f07cffd0d91c89dc6706e3d0d6a286de43 (avformat/url: check url root node when rel include double dot and trim double dot)

Change History (2)

comment:1 by Steven Liu, 18 months ago

Cc: liuqi05@kuaishou.com added
Priority: normalimportant

comment:2 by Carl Eugen Hoyos, 18 months ago

Priority: importantnormal
Resolution: duplicate
Status: newclosed

Duplicate of ticket #8674.

Note: See TracTickets for help on using tickets.