Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#7031 closed defect (invalid)

encode_video example does not work

Reported by: Jodon Owned by:
Priority: normal Component: documentation
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

I just compiled the encode_video.c example against Shift Media Project's ffmpeg for Windows (https://github.com/ShiftMediaProject). The result is that it can never find an encoder (avcodec_find_encoder_by_name always fails). This is easily fixed by adding avcodec_register_all before the call.

How to reproduce:

% ffmpeg -i encode_video.c ... encode_video
% encode_video Test.mp4 libx264
Codec 'libx264' not found

ffmpeg version: libffmpeg_3.4.1.r89955_msvc15
built a couple of weeks ago (but verified against trunk's encode_video.c).

Change History (2)

comment:1 Changed 4 months ago by jkqxz

  • Resolution set to invalid
  • Status changed from new to closed

Examples from git master are not intended to work on past releases. You are using a 3.4 release version, so you should use the 3.4 examples with it.

comment:2 Changed 4 months ago by cehoyos

  • Keywords example removed
Note: See TracTickets for help on using tickets.