Opened 11 months ago

Closed 5 months ago

Last modified 5 months ago

#6863 closed enhancement (wontfix)

Integration of GoPro Decoder/Encoder

Reported by: Garbord Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: cfhd
Cc: felix.bau@gmx.de, lev.panov@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The current Cineform codec in FFMPEG (version 3.4 at time of submitting this ticket) is not correctly playing back all footage. e.g. https://trac.ffmpeg.org/ticket/6675

Is it possible to use the recently open sourced official Cineform codec (Oct 2017). The goal would be to improve replay quality and to add the ability to encode to this format?

Github repo is found here:
https://github.com/gopro/cineform-sdk

Change History (12)

comment:1 Changed 11 months ago by Garbord

By 'use' I mean it possible to either assess suitability of directly integrating the codec, or to use information from the repo to improve the existing codec within FFMPEG?

comment:2 Changed 11 months ago by richardpl

  • Resolution set to wontfix
  • Status changed from new to closed

comment:3 Changed 11 months ago by cehoyos

  • Keywords cfhd added; Cineform GoPro Wavelet removed
  • Version changed from unspecified to git-master

comment:4 Changed 11 months ago by mvignali

Why set it to wontfix ?
Is it a legal, technical or other reason ?

comment:5 Changed 11 months ago by Garbord

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Could you please explain the won't fix status? It would be very helpful to understand the challenges of adopting the codec.

comment:6 Changed 11 months ago by kierank

Wontfix should not have been added.

comment:7 Changed 11 months ago by Cigaes

Especially not without an explanation.

comment:8 Changed 10 months ago by Djfe

  • Cc felix.bau@gmx.de added

comment:9 Changed 9 months ago by stib

I'm happy to provide test footage if anyone needs it. This is a very useful intermediate codec for post-production work, rivalling the almost-ubiquitous prores for speed and quality. But unlike proRes it has been open-sourced—something I can't see apple doing any time soon.

comment:10 Changed 7 months ago by leavittx

  • Cc lev.panov@gmail.com added

comment:11 Changed 5 months ago by kierank

  • Resolution set to fixed
  • Status changed from reopened to closed

Cineform decoder is being improved as part of GSoC.
Cineform encoder can't be incorporated into FFmpeg because it is specific to x86 processors, FFmpeg supports a much wider range of processors than x86.

comment:12 Changed 5 months ago by cehoyos

  • Resolution changed from fixed to wontfix

I don't know if the original suggestion was a good idea or not but it was certainly not fixed.

Note: See TracTickets for help on using tickets.