Opened 11 months ago

Closed 10 months ago

Last modified 10 months ago

#6862 closed defect (needs_more_info)

SRT conversion failure depends on unrelated other tracks being converted

Reported by: julian Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

there is something weird going on:

1.) download the files here ... sorry i couldn't find any other or shorter samples exhibiting this issue:
2.) for simplicity rename the mkv to mmm.mkv and the srt to mmm.srt
3.) now start conversion using ffmpeg 3.4 or current git head .. this will fail because the SRT has an unknown encoding which can't be guessed
ffmpeg -fix_sub_duration -i mmm.mkv -i mmm.srt -map 0:0 -map 0:1 -map 1:0 -scodec mov_text -vcodec copy -acodec copy mmm.mp4
4.) if do do a completely unrelated change to the command line, conversion suddenly succeeds. we tell it to also encode the internal MKV subtitle:
ffmpeg -fix_sub_duration -i mmm.mkv -i mmm.srt -map 0:0 -map 0:1 -map 1:0 -map 0:2 -scodec mov_text -vcodec copy -acodec copy mmm.mp4
i see no reason why success of the conversion depends on whether the internal subtitle is converted, when the problem is with the external SRT subtitle. i think this must be a bug. if there is a problem with the SRT, ffmpeg should fail (or succeed) regardless of whether other subtitle tracks are also specified.

attached are the full outputs of ffmpeg

note that the behaviour is the same whether -sub_charenc is omitted or if its added but specifies a wrong encoding

Attachments (1)

Archive.zip (27.6 KB) - added by julian 11 months ago.
full output of both command lines (good and bad)

Download all attachments as: .zip

Change History (3)

Changed 11 months ago by julian

full output of both command lines (good and bad)

comment:1 Changed 10 months ago by cehoyos

  • Description modified (diff)
  • Resolution set to needs_more_info
  • Status changed from new to closed

Please provide an input sample.

comment:2 Changed 10 months ago by julian

the file exibiting the issue is here: magnet:?xt=urn:btih:243f1d7a58be0f749830321129b7b6b1028e79ba&dn=Manhattan.Murder.Mystery.1993.720p.WEB-DL.AAC2.0.h264-HAi&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969&tr=udp%3A%2F%2Fzer0day.ch%3A1337&tr=udp%3A%2F%2Fopen.demonii.com%3A1337&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969&tr=udp%3A%2F%2Fexodus.desync.com%3A6969

Note: See TracTickets for help on using tickets.