Opened 10 months ago

Last modified 10 months ago

#6670 reopened defect

"LAVSplitterSource" shows empty "Chapters"(title) metadata tags for remote file.

Reported by: max79 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

iTunes can show it fully. Example:
http://www.electromixes.com/zik/electromix_v120.m4a
Summary of the bug:
ffmpeg version 3.3.3 Copyright (c) 2000-2017 the FFmpeg developers

built with gcc 7.1.0 (GCC)
configuration: --enable-gpl --enable-version3 --enable-cuda --enable-cuvid --enable-d3d11va --enable-dxva2 --enable-libmfx --enable-nvenc --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-zlib
libavutil 55. 58.100 / 55. 58.100
libavcodec 57. 89.100 / 57. 89.100
libavformat 57. 71.100 / 57. 71.100
libavdevice 57. 6.100 / 57. 6.100
libavfilter 6. 82.100 / 6. 82.100
libswscale 4. 6.100 / 4. 6.100
libswresample 2. 7.100 / 2. 7.100
libpostproc 54. 5.100 / 54. 5.100

[mov,mp4,m4a,3gp,3g2,mj2 @ 00000000004b2780] stream 0, timescale not set
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'http://www.electromixes.com/zik/electromix_v120.m4a':

Metadata:

major_brand : M4A
minor_version : 0
compatible_brands: M4A mp42isom
creation_time : 2017-08-26T11:44:04.000000Z
title : electromix 120
artist : yannick burky
genre : EDM
encoder : Fission
date : 2017
track : 0
disc : 0

Duration: 00:59:44.07, start: -19.713700, bitrate: 152 kb/s

Chapter #0:0: start 0.000000, end 19.713700
Metadata:

title : electromixes

Chapter #0:1: start 19.713700, end 192.446900
Metadata:

title :

Chapter #0:2: start 192.446900, end 401.890800
Metadata:

title :

Chapter #0:3: start 401.890800, end 642.844300
Metadata:

title :

Chapter #0:4: start 642.844300, end 872.861200
Metadata:

title :

Chapter #0:5: start 872.861200, end 1068.094600
Metadata:

title :

Chapter #0:6: start 1068.094600, end 1244.798400
Metadata:

title :

Chapter #0:7: start 1244.798400, end 1398.886100
Metadata:

title :

Chapter #0:8: start 1398.886100, end 1563.190400
Metadata:

title :

Chapter #0:9: start 1563.190400, end 1745.258100
Metadata:

title :

Chapter #0:10: start 1745.258100, end 1935.243800
Metadata:

title :

Chapter #0:11: start 1935.243800, end 2250.686800
Metadata:

title :

Chapter #0:12: start 2250.686800, end 2427.390700
Metadata:

title :

Chapter #0:13: start 2427.390700, end 2639.597900
Metadata:

title :

Chapter #0:14: start 2639.597900, end 2801.278500
Metadata:

title :

Chapter #0:15: start 2801.278500, end 3019.847900
Metadata:

title :

Chapter #0:16: start 3019.847900, end 3220.189600
Metadata:

title :

Chapter #0:17: start 3220.189600, end 3435.508300
Metadata:

title :

Chapter #0:18: start 3435.508300, end 3568.930100
Metadata:

title :

Chapter #0:19: start 3568.930100, end 3584.069600
Metadata:

title :

Stream #0:0(eng): Audio: aac (LC) (mp4a / 0x6134706D), 44100 Hz, stereo, fltp, 127 kb/s (default)
Metadata:

creation_time : 2017-08-26T11:44:04.000000Z

Stream #0:1(eng): Data: bin_data (tx3g / 0x67337874), 0 kb/s
Metadata:

creation_time : 2017-08-26T11:44:03.000000Z

Stream #0:2(eng): Video: mjpeg (jpeg / 0x6765706A), yuvj420p(pc, bt470bg/unknown/unknown), 3300x3300 [SAR 72:72 DAR 1:1], 20 kb/s, 0.01 fps, 10k tbr, 10k tbn, 10k tbc (default)
Metadata:

creation_time : 2017-08-26T11:44:03.000000Z
encoder : Photo - JPEG

Stream #0:3(eng): Data: bin_data (tx3g / 0x67337874) (default)
Metadata:

creation_time : 2017-08-26T11:44:04.000000Z

Stream #0:4: Video: png, rgb24(pc), 1400x1400, 90k tbr, 90k tbn, 90k tbc

At least one output file must be specified

Attachments (1)

LAVsource_TitleTAG-issue.zip (644.6 KB) - added by max79 10 months ago.
LAVsource_TitleTAG-issue

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please either explain how this can be reproduced with current FFmpeg git head or explain why it cannot be reproduced.

Changed 10 months ago by max79

LAVsource_TitleTAG-issue

comment:2 Changed 10 months ago by max79

Thank you for response! Don't you see that ffmpeg shows only this:

title :

but it must show like this:

title : ####here a song name####

The problem is that the LAVSource[64-bit] can(sometimes!) show this metatag only on first MPC-HC[64-bit] start attempt all other been unsuccessful. Please look at the pics in attachment.

comment:3 Changed 10 months ago by max79

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.