Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#561 closed defect (fixed)

can not play my H264-TS 1080P file, audio is OK,but video is not OK.

Reported by: wanderman Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: H264 mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

the git-master can not play my h264 ts file(1080P).

Attachments (1)

H264-TS-CanNotBePlayedSmoothly1080P-zw3.ts (2.3 MB) - added by wanderman 5 years ago.
same as ticket#555's files

Change History (12)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 5 years ago by wanderman

cmd is: ffplay H264-TS-CanNotBePlayedSmoothly1080P-zw3.ts

comment:3 Changed 5 years ago by wanderman

  • Resolution invalid deleted
  • Status changed from closed to reopened

Changed 5 years ago by wanderman

same as ticket#555's files

comment:4 Changed 5 years ago by cehoyos

What is missing to make this a valid ticket:
The ffmpeg command line you are using to reproduce your problem.
The complete, uncut output from the console when running your command line.
What is wrong with result.

Since you believe this is a regression, please use git bisect to find the commit introducing the regression.

comment:5 Changed 5 years ago by wanderman

to reproduce this problem's command line is: cmd is: ffplay H264-TS-CanNotBePlayedSmoothly1080P-zw3.ts .
the output is :the audio output is OK, the video output is not continuely, abviously abnormal.
I am sure this is problem. if you run the above command with the newest compiled ffplay.exe, you will find.
annother biger ts file H264-TS-CanNotBePlayedSmoothly1080P-zw2.ts is uploaded to http://upload.ffmpeg.org/upload/ .

Last edited 5 years ago by wanderman (previous) (diff)

comment:6 follow-up: Changed 5 years ago by cehoyos

Is the problem reproducible with ffmpeg (the application)? Only report ffplay problems if they are unreproducible with ffmpeg.
In any case, please provide complete, uncut output (copy what ffmpeg prints on the console and paste it here) is missing.

comment:7 in reply to: ↑ 6 Changed 5 years ago by wanderman

Sorry, no output with ffmpeg!

$ ffmpeg -i H264-TS-CanNotBePlayedSmoothly1080P-zw3.ts

$

Replying to cehoyos:

Is the problem reproducible with ffmpeg (the application)? Only report ffplay problems if they are unreproducible with ffmpeg.
In any case, please provide complete, uncut output (copy what ffmpeg prints on the console and paste it here) is missing.

comment:8 Changed 5 years ago by cehoyos

  • Keywords NOT PLAYED 1080P removed
  • Priority changed from important to normal

Please upload your longer sample to http://www.datafilehost.com/ and post the link here.

comment:10 Changed 5 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 2 years ago by cehoyos

  • Keywords mpegts added; TS removed
Note: See TracTickets for help on using tickets.