Opened 4 years ago

Last modified 6 weeks ago

#5570 open enhancement

POWER8 VSX vectorization libswscale/input.c

Reported by: edelsohn Owned by:
Priority: wish Component: swscale
Version: git-master Keywords: bounty vsx
Cc: linuxer@xakep.ru Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Optimize approximately 50 functions in libswscale/input.c for POWER8 VSX SIMD instructions on PPC64 Linux.

Change History (10)

comment:1 Changed 4 years ago by edelsohn

  • Keywords bounty added
  • Version changed from unspecified to git-master

comment:2 Changed 4 years ago by cehoyos

  • Priority changed from normal to wish
  • Status changed from new to open

comment:3 Changed 4 years ago by mikelieman

commit 1df908f33f658979b32599489ca6f1a39821013c breaks build on not POWER8 VSX SIMD

make -C ffmpeg libswscale/libswscale.a
make[1]: Entering directory '/home/mike/software/mplayer/ffmpeg'
CC libswscale/swscale.o
libswscale/swscale.c:569:9: error: use of undeclared identifier 'HAVE_VSX'

if (HAVE_VSX && (!HAVE_BIGENDIAN)) {

common.mak:60: recipe for target 'libswscale/swscale.o' failed
make[1]: Leaving directory '/home/mike/software/mplayer/ffmpeg'
Makefile:740: recipe for target 'ffmpeg/libswscale/libswscale.a' failed

comment:4 Changed 4 years ago by cehoyos

  • Keywords vsx added

comment:5 Changed 2 months ago by reverse_forever

  • Resolution set to fixed
  • Status changed from open to closed

comment:6 Changed 2 months ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 2 months ago by reverse_forever

  • Cc linuxer@xakep.ru added

PPC input.c coverage now exceeds no vsx cpu. Speedups 2-12x, usually in line with no vsx cpu. Some functions got speed less than cpu, because it is impossible to vectorize them correctly(For example palToUV, palToY)I commented on them. Some functions got speed equivalent no vsx cpu(For example planar_rgb16_to_a)

Sorry for accidentally closing the ticket. As the reporter, you should close it.

comment:8 Changed 2 months ago by cehoyos

  • Status changed from reopened to open

You should remove the pal functions from your patch: They were not needed, even more so if they show no significant speed improvement.

On this bug tracker, tickets get closed once the patch gets committed.

comment:9 Changed 2 months ago by reverse_forever

Yes, pal functions was removed from patch.

comment:10 Changed 6 weeks ago by reverse_forever

Please, check my patch. I have been waiting for its commiting more than a year. I want to get my bounty from bountysource platform.

Note: See TracTickets for help on using tickets.