Opened 3 years ago

Closed 3 years ago

#4953 closed defect (needs_more_info)

FFMPEG Crash on windows 2012 server

Reported by: sonalsshah Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: crash
Cc: sonal.shah@synoverge.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

How to reproduce:
We have used below command with latest exe

ffmpeg -i Test.mp4 -vf scale=1280:720 -dframes 1124k -r 25 -b:v 1181k test1.mp4

After running this command application is crashing. I am not able to find any error on screen.
Herewith I am sharing the Log as well as test.mp4 inside zip
for testing.

Please suggest us quickly as it is very critical to fix this bug on priority.

Thanks,
Sonal Shah

Attachments (2)

ffmpeg-20151021-020816.log (6.8 KB) - added by sonalsshah 3 years ago.
Log File
ffmpeg-20151027-041233.log (7.6 KB) - added by sonalsshah 3 years ago.
Log with -f lavfi -i testsrc command

Download all attachments as: .zip

Change History (21)

comment:1 Changed 3 years ago by sonalsshah

  • Cc sonal.shah@synoverge.com added
  • Keywords Mp4 conversion added
  • Reproduced by developer set

Changed 3 years ago by sonalsshah

Log File

comment:2 Changed 3 years ago by sonalsshah

  • Priority changed from normal to critical

comment:3 Changed 3 years ago by cehoyos

  • Keywords crash added; Mp4 conversion removed
  • Priority changed from critical to normal
  • Reproduced by developer unset
  • Version changed from unspecified to git-master

Is a specific source file needed to reproduce the crash or is the crash also reproducible with -f lavfi -i testsrc? If a specific source file is needed, please provide it.
Is the issue only reproducible with (implicit) -vcodec libx264 or also with -qscale 2 -vcodec mpeg4?

comment:4 Changed 3 years ago by sonalsshah

Actually It is applicable to all mp4 files.

We have not tried -f lavfi -i testsrc options yet.

We were not able to reproduce same issue on windows7 machine with this command. problem in out windows 2012 server (Production only)

Thanks,
Sonal Shah

comment:5 Changed 3 years ago by cehoyos

Please test with testsrc input and mpeg4 encoding.
Does the same binary that crashes on one computer work on another one?

comment:6 Changed 3 years ago by sonalsshah

Yes it is working in another machine

comment:7 Changed 3 years ago by cehoyos

Is the crash also reproducible if you use -f lavfi -i testsrc as input?
Is the crash also reproducible if you use -vcodec mpeg4 -qscale 2 instead of h264 encoding?

comment:8 Changed 3 years ago by sonalsshah

I have tried option libx264 and mpeg4. Issue occurred with Linx264 not with mpeg4. But File Size is 3 times higher than original file.

Last edited 3 years ago by sonalsshah (previous) (diff)

comment:9 Changed 3 years ago by sonalsshah

Can you please help us as we are really need to fix this problem in the production.

Thanks in advance.

Last edited 3 years ago by sonalsshah (previous) (diff)

comment:10 Changed 3 years ago by cehoyos

Is the crash also reproducible if you use -f lavfi -i testsrc as input?

comment:11 Changed 3 years ago by sonalsshah

We have used below command. still facing the error.

c:\ffmpeg\bin\ffmpeg -i Test.mp4 -vf scale=1280:720 -dframes 1124k -r 25 -b:v 1181k test1.mp4 -report -f lavfi -i testsrc

Herewith I am attaching the log file.

Changed 3 years ago by sonalsshah

Log with -f lavfi -i testsrc command

comment:12 Changed 3 years ago by cehoyos

Please test the following:

$ ffmpeg -f lavfi -i testsrc -vcodec libx264 -t 10 out.mp4

(And please confirm that it works with -vcodec mpeg4 on the same system.)

Last edited 3 years ago by cehoyos (previous) (diff)

comment:13 Changed 3 years ago by cehoyos

And please try to verify that Windows 2012 is not installed on a Virtual Machine claiming to run on a Pentium-M with SSSE3.

comment:14 Changed 3 years ago by sonalsshah

Application is crashed for the $ ffmpeg -f lavfi -i testsrc -vcodec libx264 -t 10 out.mp4

Application is worked for $ ffmpeg -f lavfi -i testsrc -vcodec mpeg4 -t 10 out.mp4

Please suggest.

comment:15 Changed 3 years ago by cehoyos

Please verify that Windows 2012 is not installed on a Virtual Machine claiming to run on a Pentium-M with SSSE3.

comment:16 Changed 3 years ago by sonalsshah

We have dedicated Windows 2012 server.
Processor: Xeon E3-1265L
Type: Quad Core
Threads: 8
Speed/core: 2.5 GHz

Please suggest asap.

comment:17 Changed 3 years ago by sonalsshah

Can you please help us as we are really need to fix this problem in the production.

Thanks in advance.

comment:18 Changed 3 years ago by cehoyos

Please compile yourself: If the problem is still reproducible, provide backtrace etc. as explained on https://ffmpeg.org/bugreports.html

comment:19 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can add the missing information: I was unable to reproduce on Windows 2012 Server.

Note: See TracTickets for help on using tickets.