Opened 4 years ago

Closed 4 years ago

#4952 closed defect (fixed)

ffplay unexpectedly sends "RTSP/1.0 501 Not Implemented" and stop decoding

Reported by: ioeir2 Owned by:
Priority: important Component: avformat
Version: git-master Keywords: rtsp regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ffplay rtsp://176.106.65.249:555/12 -rtsp_transport tcp
ffmpeg 2.8, 2.8.1, latest git 

After about 30 seconds ffplay stops decoding image and sends a couple "RTSP/1.0 501 Not Implemented" to the RTSP server.

The error introduced in commit 764ec70149728be82304c163ccc4e280f1629201 on Jul 30, 2015. Reverting this commit fix the issue. No such issue on ffmpeg 2.7.2 version.

Attachments (2)

rtsp_camera_2.8.1.pcapng (693.8 KB) - added by ioeir2 4 years ago.
Wireshark dump
ffplay-20151021-002844.log (80.1 KB) - added by ioeir2 4 years ago.
Report

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by ioeir2

Wireshark dump

Changed 4 years ago by ioeir2

Report

comment:1 Changed 4 years ago by cehoyos

  • Component changed from ffmpeg to avformat
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

comment:2 Changed 4 years ago by cehoyos

Regression since bc4bdc6d

comment:3 Changed 4 years ago by ioeir2

Access to rtsp://176.106.65.249:555/12 will be available till Oct 31, 2015.

comment:4 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Martin Storsjö since 12e95d156ae95e7db7f5a524112569b29cbdf0be
Thank you for the report!

Note: See TracTickets for help on using tickets.