Opened 3 years ago

Last modified 2 years ago

#4735 reopened license violation

Kaltura ships ffmpeg with --non-free and violates (L)GPL

Reported by: kierank Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Following discussion on IRC I put this here:

Kaltura's buildscripts include ffmpeg built with non-free:
https://github.com/kaltura/platform-install-packages/blob/e1c259a8b04bbcdb1134b5fb2621d3286c775e49/deb/kaltura-ffmpeg/debian/rules

This was reported to them but no change for two months:
https://github.com/kaltura/platform-install-packages/issues/392

Change History (8)

comment:1 Changed 3 years ago by Cigaes

The script itself is not infringement. Do they distribute the resulting binaries?

comment:2 Changed 3 years ago by kierank

Yes: http://installrepo.kaltura.org/releases/

--prefix=opt/kaltura/ffmpeg-2.1.3 --libdir=opt/kaltura/ffmpeg-2.1.3/lib --shlibdir=opt/kaltura/ffmpeg-2.1.3/lib --extra-cflags=' -fPIC -I/opt/kaltura/include' --extra-ldflags=-L/opt/kaltura/lib --disable-devices --enable-bzlib --enable-libfaac --enable-libgsm --enable-libmp3lame --enable-libschroedinger --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-filter=movie --enable-avfilter --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libvpx --enable-libspeex --enable-libass --enable-postproc --enable-pthreads --enable-static --enable-shared --enable-gpl --disable-debug --disable-optimizations --enable-libfdk-aac --enable-nonfree --enable-gpl --enable-nonfree --enable-libfdk-aac --enable-pthreads --enable-swscale --enable-vdpau --enable-bzlib --disable-devices --enable-filter=movie --enable-version3 --enable-x11grab

Last edited 3 years ago by kierank (previous) (diff)

comment:3 Changed 3 years ago by jessp01

Hello,

I would just like to update you that we are in the process of attempting to utilise ffmpeg's internal implementation of AAC, mentioned here:
https://trac.ffmpeg.org/wiki/Encode/HighQualityAudio

That would mean we can eliminate use of FDK_AAC and libfaac and therefore will no longer require the nonfree compilation flag.

I will keep you posted shortly.

Thanks,

comment:5 Changed 3 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open

I just downloaded the fine kaltura-ffmpeg2.1.3_amd64.deb (size 13073854, md5sum 045ce00de2b68dba8469e39111cffa08): It is a binary distribution of FFmpeg, contains non-free libraries and was compiled with the --enable-nonfree option.

comment:6 Changed 2 years ago by jessp01

  • Resolution set to fixed
  • Status changed from open to closed

Hello,

You did not specify where you got the deb from but I assume it was from:
http://installrepo.kaltura.org/releases/kaltura-ffmpeg2.1.3_amd64.deb

This was an old left over which I just deleted. It was never actually used when installing Kaltura CE nor was it referenced in any of our repos.

Note that since we make use of a CDN, it may take time for it to be updated cross all edges.

If you see it anywhere else, please let me know.

comment:7 Changed 2 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Where can I find the current installer?

comment:8 Changed 2 years ago by cehoyos

The MEncoder distribution I found still contains a non-free version of libavcodec linked against libfaac.

Note: See TracTickets for help on using tickets.