Opened 11 years ago

Closed 11 years ago

#465 closed defect (invalid)

Incorrect height after avcodec_open

Reported by: DonMoir Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

With the attached file, the AVCodecContext height is wrong after you do avcodec_open. Before you call avcodec_open the height is correct. When rendering, the frame has the correct height. The correct height for this file is 216. After avcodec_open, the AVCodecContext height is 224.

I have not noticed this problem with any other file. ffplay gets this wrong. Problem occurs with any ffmpeg build I have tried.

Attachments (1)

test.flv (1.1 MB ) - added by DonMoir 11 years ago.

Download all attachments as: .zip

Change History (3)

by DonMoir, 11 years ago

Attachment: test.flv added

comment:1 by Carl Eugen Hoyos, 11 years ago

Complete, uncut output missing.

comment:2 by Stefano Sabatini, 11 years ago

Analyzed by developer: set
Resolution: invalid
Status: newclosed

Closing the ticket as I don't have enough information for analyzing it, ffprobe/ffplay/ffmpeg all seem to correctly interpret the size of the video stream.

Please provide a minimal code sample if the problem is related to the API.

Note: See TracTickets for help on using tickets.