Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3975 closed enhancement (duplicate)

FFProbe invalid data through pipe:0

Reported by: InoMurko Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: mjpeg
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

cat JPGExample.jpg | ./ffprobe -i pipe:0 -print_format json -show_streams -show_format
{
pipe:0: Invalid data found when processing input

}

cat PNGExample.png | ./ffprobe -i pipe:0 -print_format json -show_streams -show_format
Works. Prints valid JSON.

Also works fine.
./ffprobe -i JPGExample.jpg -print_format json -show_streams -show_format
./ffprobe -i PNGExample.png -print_format json -show_streams -show_format

Attachments (2)

JPGExample.JPG (8.3 KB) - added by InoMurko 4 years ago.
Does not work.
PNGExample.png (1.5 MB) - added by InoMurko 4 years ago.
Works.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by InoMurko

Does not work.

Changed 4 years ago by InoMurko

Works.

comment:1 Changed 4 years ago by InoMurko

  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 4 years ago by cehoyos

  • Component changed from ffprobe to avformat
  • Keywords mjpeg added; pipe show format show streams removed
  • Priority changed from normal to wish
  • Reproduced by developer unset
  • Resolution changed from invalid to duplicate
  • Type changed from defect to enhancement
  • Version changed from 2.4.1 to git-master

Duplicate of ticket #2541

comment:3 Changed 4 years ago by cehoyos

Ticket #2541 was fixed, I believe this issue should also work fine now.

Note: See TracTickets for help on using tickets.