Opened 4 years ago

Closed 2 years ago

#2541 closed enhancement (fixed)

Autodetect image file codecs

Reported by: cyril Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: image2 mjpeg probe
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

$ ffmpeg -vcodec mjpeg -i phoebe-4096.png
ffmpeg version N-52834-g974420a Copyright (c) 2000-2013 the FFmpeg developers
  built on May  6 2013 23:51:34 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 29.100 / 52. 29.100
  libavcodec     55.  7.100 / 55.  7.100
  libavformat    55.  4.101 / 55.  4.101
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 63.101 /  3. 63.101
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
Input #0, image2, from 'phoebe-4096.png':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: mjpeg, gray, 4096x2049 [SAR 72:72 DAR 4096:2049], 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Attachments (1)

phoebe-4096.png (456.3 KB) - added by cyril 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by cyril

comment:1 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Description modified (diff)
  • Keywords image2 mjpeg added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from ffplay can't read a .png file to Autodetect image file codecs
  • Type changed from defect to enhancement

comment:2 Changed 3 years ago by Đonny

Ticket #3616 has been marked as duplicate to this one.
I'm not sure if the nature of these two tickets is same. I realized that if I have file (see http://docs.voanews.eu/en-US-TEST-LTR/2014/05/06/f35d1270-fa55-4f82-aefc-e3db136aa395.avi). and run ffprobe on it (without any additional parameters)

ffprobe xxx.xxx

the results are different depending on extension of the file (at least on Windows)

  • When xxx.avi - the file is mistedtedted as avi
    [avi @ 0000000002a44920] Format avi detected only with low score of 1, misdetection possible!
    MJPEG.avi: Invalid data found when processing input
    
  • When xxx (w/o extension)
    MJPEG.xxx: Invalid data found when processing input
    
  • When xxx.mjpeg it works fine

I guess it is caused by ffmpeg not being able to recognize that the file is MJPEG format.

comment:3 Changed 2 years ago by cehoyos

  • Keywords probe added
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in 88c937fd

Note: See TracTickets for help on using tickets.