Opened 7 years ago

Closed 7 years ago

#3844 closed defect (fixed)

"Could not find codec parameters" when playing MP3

Reported by: Matthew Schauer Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mpegts mp3 probe regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I'm running FFmpeg 2.3.1 from the Arch Linux repository. There is an MP3 file that I am unable to play with mplayer, mpv, or ffplay and unable to convert or manipulate with ffmpeg. However, VLC and mpg123 play the file fine without complaining. This surprises me, since FFmpeg has a great track record with buggy/damaged media files. The file in question can be downloaded at http://tuutenn.s66.xrea.com/music/tuu_gekisinn.mp3 .

Output of ffplay:

$ ffplay tuu_gekisinn.mp3
ffplay version 2.3.1 Copyright (c) 2003-2014 the FFmpeg developers
  built on Jul 31 2014 14:51:38 with gcc 4.9.1 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --enable-avisynth --enable-avresample --enable-decoder=atrac3 --enable-decoder=atrac3p --enable-dxva2 --enable-fontconfig --enable-gnutls --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-pic --enable-postproc --enable-runtime-cpudetect --enable-shared --enable-swresample --enable-vdpau --enable-version3 --enable-x11grab
  libavutil      52. 92.100 / 52. 92.100
  libavcodec     55. 69.100 / 55. 69.100
  libavformat    55. 48.100 / 55. 48.100
  libavdevice    55. 13.102 / 55. 13.102
  libavfilter     4. 11.100 /  4. 11.100
  libavresample   1.  3.  0 /  1.  3.  0
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
[mpegts @ 0x7fa85c0008c0] PES packet size mismatchsq=    0B f=0/0   
[mpegts @ 0x7fa85c0008c0] nothing to probe for stream 0
[mpegts @ 0x7fa85c0008c0] probed stream 0 failed
[mpegts @ 0x7fa85c0008c0] probed stream 1 failed
[mpegts @ 0x7fa85c0008c0] PES packet size mismatch
[mpegts @ 0x7fa85c0008c0] Could not find codec parameters for stream 0 (Unknown: none): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x7fa85c0008c0] Could not find codec parameters for stream 1 (Unknown: none): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
tuu_gekisinn.mp3: could not find codec parameters

The error occurs regardless of the values of analyzeduration and probesize. The output of ffmpeg -report -i tuu_gekisinn.mp3 is attached.

Attachments (2)

ffmpeg-20140810-153431.log (136.8 KB ) - added by Matthew Schauer 7 years ago.
ffmpeg -report -i tuu_gekisinn.mp3
tuu_gekisinn_cut.mp3 (2.4 MB ) - added by Carl Eugen Hoyos 7 years ago.

Change History (4)

by Matthew Schauer, 7 years ago

Attachment: ffmpeg-20140810-153431.log added

ffmpeg -report -i tuu_gekisinn.mp3

by Carl Eugen Hoyos, 7 years ago

Attachment: tuu_gekisinn_cut.mp3 added

comment:1 by Carl Eugen Hoyos, 7 years ago

Component: undeterminedavformat
Keywords: mpegts mp3 probe regression added
Priority: normalimportant
Reproduced by developer: set
Status: newopen
Version: 2.3git-master

Regression since 7ea39638 - related to ticket #580.
Attached cut sample produces different output but also no playback. The complete sample is in http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket3844/

At least the first 19120 bytes of the sample are garbage.

$ ffmpeg -i tuu_gekisinn.mp3 -i tuu_gekisinn_cut.mp3
ffmpeg version N-65510-g49456a9 Copyright (c) 2000-2014 the FFmpeg developers
  built on Aug 11 2014 01:05:36 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      54.  1.100 / 54.  1.100
  libavcodec     56.  0.100 / 56.  0.100
  libavformat    56.  0.100 / 56.  0.100
  libavdevice    56.  0.100 / 56.  0.100
  libavfilter     5.  0.100 /  5.  0.100
  libswscale      3.  0.100 /  3.  0.100
  libswresample   1.  0.100 /  1.  0.100
  libpostproc    53.  0.100 / 53.  0.100
[mpegts @ 0x33c0ce0] PES packet size mismatch
[mpegts @ 0x33c0ce0] nothing to probe for stream 0
[mpegts @ 0x33c0ce0] probed stream 0 failed
[mpegts @ 0x33c0ce0] probed stream 1 failed
[mpegts @ 0x33c0ce0] PES packet size mismatch
[mpegts @ 0x33c0ce0] Could not find codec parameters for stream 0 (Unknown: none): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 0x33c0ce0] Could not find codec parameters for stream 1 (Unknown: none): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
tuu_gekisinn.mp3: could not find codec parameters
Input #0, mpegts, from 'tuu_gekisinn.mp3':
  Duration: N/A, bitrate: N/A
    Stream #0:0[0x963]: Unknown: none
    Stream #0:1[0xb57]: Unknown: none
tuu_gekisinn_cut.mp3: could not find codec parameters

comment:2 by Michael Niedermayer, 7 years ago

Resolution: fixed
Status: openclosed
Note: See TracTickets for help on using tickets.