Opened 5 years ago

Closed 5 years ago

#3646 closed defect (wontfix)

caf muxer doesn't write correct format id in desc chunk for ALAC

Reported by: nu774 Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords: caf
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

How to reproduce:

% ffmpeg -i foo.alac.m4a -c:a copy bar.alac.caf

In case of ALAC, mFormatID field of desc chunk has to be one of the following:
1: 16bit
2: 20bit
3: 24bit
4: 32bit
ffmpeg caf muxer always writes zero.
This is not very important since these information is included in codec startup data (magic cookie), but incorrect anyway.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords caf added

Please add console output to all tickets.

comment:2 Changed 5 years ago by cehoyos

  • Analyzed by developer set
  • Resolution set to wontfix
  • Status changed from new to closed

The caf specification says that Apple Lossless in caf has no format flags.

Apple's own (muxing and demuxing) implementation is apparently different but since this requires some (minor) effort and the resulting files could theoretically be rejected by overcautious demuxers and would not fix any existing demuxers, I suggest not to change current FFmpeg behaviour.

Please reopen if the specification I read is outdated (was changed) or I misunderstood or if there is software that requires the format flags for alac.

Note: See TracTickets for help on using tickets.