Opened 5 years ago

Closed 5 years ago

#3645 closed defect (fixed)

Remuxing adpcm_ms to caf fails for some samples

Reported by: nu774 Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: caf
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

How to reproduce:

% ffmpeg -i foo.wav -c:a adpcm_ms bar.caf

The resulting file seems to be playable by ffmpeg based software, but not by QuickTime? 7.

Attachments (1)

MSADPCM.wav (1.4 MB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords caf added
  • Priority changed from important to normal

Please provide the complete, uncut console output to make this a valid ticket.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

I was unable to reproduce this (only tested with QuickTime? 7).

I would like to fix this (if there is an issue) so please reopen if you can add any additional information.

comment:3 Changed 5 years ago by nu774

OK, it seems that MS-ADPCM encoded by ffmpeg seems to be playable on QuickTime? as you say, so my report was improper.
What I actually tried was remuxing from existing MS-ADPCM wav file encoded by Microsoft standard MS-ADPCM ACM codec.
Please look at samples at https://dl.dropboxusercontent.com/u/76042064/MSADPCM_samples.zip .
In the zip archive contained :

  • MSADPCM.wav: the original WAV file, encoded by Microsoft ACM codec.
  • MSADPCM.caf: Remuxed into CAF by Apple API, contains kuki chunk, playable by QuickTime?.
  • MSADPCM.ffmpeg.caf: Remuxed into CAF by ffmpeg, lacks kuki chunk, not correctly playable by QuickTime?.

As far as I understand, MSADPCM codec needs some codec setup data (coefs) that are stored in ADPCMWAVEFORMAT defined in mmreg.h, which goes under fmt chunk in case of WAV file / kuki chunk in case of CAF.

comment:4 Changed 5 years ago by cehoyos

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

Don't you agree that you would save both of us time if you just pasted the command line that produces the unplayable output together with the complete, uncut console output?

Changed 5 years ago by cehoyos

comment:5 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from caf muxer doesn't write kuki chunk for adpcm_ms to Remuxing adpcm_ms to caf fails for some samples
  • Version changed from unspecified to git-master

Should be fixed in 1acb5ca0 - thank you for the report!

Note: See TracTickets for help on using tickets.