Opened 5 years ago

Closed 5 years ago

#295 closed defect (fixed)

qt-faststart segfaults after complaining of non-existent output directory

Reported by: rbanffy Owned by: michael
Priority: normal Component: undetermined
Version: 0.6.3 Keywords: qt-faststart path
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

When doing

"qt-faststart infile.mp4 ./non-existent-directory/outfile.mp4" the program crashes with a segfault after reporting the file/directory doesn't exist.

$ qt-faststart infile.mp4 ./non-existent-directory/outfile.mp4
ftyp 0 32
free 32 8
mdat 40 10084256
moov 10084296 51144

patching stco atom...
patching stco atom...

./non-existent-folder/out.mp4: No such file or directory
Segmentation fault

The message, along with the segfault, made it a bit confusing - it took me a while to figure out the problem was the missing folder.

Change History (3)

comment:1 Changed 5 years ago by rbanffy

$ qt-faststart infile.mp4 ./non-existent-directory/outfile.mp4
ftyp 0 32
free 32 8
mdat 40 10084256
moov 10084296 51144

    patching stco atom...
    patching stco atom...

./non-existent-folder/out.mp4: No such file or directory
Segmentation fault

comment:2 Changed 5 years ago by saste

Unreproducible here, with both 0.6.4 and master.

Please provide the gdb output, and/or more information regarding the build (version and platform).

comment:3 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

I can reproduce the problem, it has been fixed some time ago, both 0.7 (compatible to 0.6.3) and 0.8 contain the fix.

Note: See TracTickets for help on using tickets.