Opened 4 years ago

Closed 4 years ago

#2630 closed defect (fixed)

Log output is blocking

Reported by: bjartnes Owned by:
Priority: normal Component: ffplay
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

Not sure if this is labelled a bug or more a new feature/feature change but it was mentioned that it might should be raised with ffmpeg.

The issue is that when I pipe video in node.js to a ffplay child-process the log output is blocking. This means that after a while playing the video will halt because the output buffer from stdout fills up with progress information. It's easy to work around, but it was claimed that it seems unnescessary to block on log output. I myself have no strong opinions on the issue, but I thought I should bring it up.

https://github.com/joyent/node/issues/5610

Change History (5)

comment:1 Changed 4 years ago by bjartnes

blog=>block. Could not find edit button.

comment:2 Changed 4 years ago by cehoyos

  • Keywords log output blocking removed
  • Priority changed from minor to normal
  • Type changed from enhancement to defect
  • Version changed from 1.1.5 to git-master

Command line and complete, uncut console output missing.

I wanted to write "aren't you searching for -loglevel 0 ?" but there appears to be a bug in ffplay iiuc.

comment:3 Changed 4 years ago by cehoyos

I may misunderstand the ticket, but you could test this patch with -loglevel 30 (or smaller):
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/164562

comment:4 Changed 4 years ago by cehoyos

  • Description modified (diff)

comment:5 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

I believe this bug should be fixed since 3b491c5 but as said I may misunderstand, please reopen this ticket if the problem is still reproducible with git head.

Note: See TracTickets for help on using tickets.