Opened 6 years ago

Closed 5 years ago

#241 closed enhancement (fixed)

FFmpeg does not find mpeg program stream in the file playable with QuickTime player

Reported by: svolvo Owned by: michael
Priority: wish Component: avformat
Version: git-master Keywords: mov mpegps m1s
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Attached file is playable with QuickTime? player. However when I run the following command

ffmpeg -i "Animals 2004.mov"

I receive the output saying there is no Audio/Video? streams:

....
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Animals 2004.mov':

Metadata:

major_brand : qt
minor_version : 537199360
compatible_brands: qt
creation_time : 2007-09-11 15:53:56

Duration: 00:00:53.05, start: 0.000000, bitrate: 1236 kb/s

Stream #0.0(eng): Data: m1s / 0x2073316D, 1236 kb/s
Metadata:

creation_time : 2007-09-11 15:53:56

Same thing happens on Linux attemping to open this movie with mplayer. It reports no playable streams in the movie.

Is it a bug in FFmpeg?

Attachments (1)

Animals2004.mov (2.0 MB) - added by svolvo 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by svolvo

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to avformat
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Type changed from defect to enhancement
  • Version changed from 0.6.3 to git-master

Attached mov file (Video and Audio, MPEG1, 29.97fps, 480x360) can not be read with FFmpeg.

$ ffmpeg -i Animals2004.mov
ffmpeg version git-N-30224-gb49728d, Copyright (c) 2000-2011 the FFmpeg developers
  built on May 25 2011 22:20:37 with gcc 4.5.3
  configuration: --cc='/usr/local/gcc-4.5.3/bin/gcc -m32' --enable-gpl
  libavutil    51.  2. 2 / 51.  2. 2
  libavcodec   53.  6. 0 / 53.  6. 0
  libavformat  53.  2. 0 / 53.  2. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2. 11. 0 /  2. 11. 0
  libswscale    0. 14. 0 /  0. 14. 0
  libpostproc  51.  2. 0 / 51.  2. 0
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x8cb3b20] Could not find codec parameters (Data: m1s  / 0x2073316D, 1236 kb/s)
Animals2004.mov: could not find codec parameters

comment:2 Changed 6 years ago by svolvo

I was unable to upload the original file because of ~8Mb size. One I uploaded was cut off accordingly to directions on ffmpeg.org (linux dd...). If you'd like to have the original file please send me directions to do that.

comment:3 Changed 6 years ago by cehoyos

Works fine with ffmpeg -f mpeg Animals2004.mov

comment:4 Changed 6 years ago by cehoyos

  • Keywords mov mpeg added

comment:5 Changed 5 years ago by cehoyos

  • Keywords m1s added

comment:6 Changed 5 years ago by cehoyos

  • Keywords mpegps added; mpeg removed
  • Summary changed from FFmpeg does not find streams in the file playable with QuickTime player to FFmpeg does not find mpeg program stream in the file playable with QuickTime player

comment:7 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Petter Ericson.

Note: See TracTickets for help on using tickets.