Opened 7 years ago

Closed 7 years ago

#2276 closed defect (duplicate)

Different muxing behavior on different version of ffmpeg

Reported by: endlessroad1991 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: h264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Same muxing command:

./ffmpeg -y -r 15 -i 1.h264 -vcodec copy 1.mp4

ffmpeg 0.10.6 and 1.1.2, both configured with:

--disable-everything --enable-muxer=mp4 --enable-muxer=adts --enable-bsf=aac_adtstoasc --enable-demuxer=mov --enable-demuxer=h264 --enable-demuxer=aac --enable-protocol=file --enable-decoder=aac --enable-decoder=rawvideo --enable-decoder=h264 --enable-parser=h264 --enable-parser=aac

generates different results.

Original fps of 1.h264 is 15. ffmpeg 0.10.6 changes fps to 15fps, as specified by "-r 15". However, ffmpeg 1.1.2 doesn't change the fps.
I checked "ffmpeg -h" for both versions, and it seems that usage of "-r" hasn't changed.
Any ideas?

ffmpeg 0.10.6:

ffmpeg version 0.10.6 Copyright (c) 2000-2012 the FFmpeg developers
  built on Feb 18 2013 15:40:53 with llvm_gcc 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)
  configuration: --disable-everything --enable-muxer=mp4 --enable-muxer=adts --enable-bsf=aac_adtstoasc --enable-demuxer=mov --enable-demuxer=h264 --enable-demuxer=aac --enable-protocol=file --enable-decoder=aac --enable-decoder=rawvideo --enable-decoder=h264 --enable-parser=h264 --enable-parser=aac
  libavutil      51. 35.100 / 51. 35.100
  libavcodec     53. 61.100 / 53. 61.100
  libavformat    53. 32.100 / 53. 32.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 61.100 /  2. 61.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  6.100 /  0.  6.100

ffmpeg 1.1.2:

ffmpeg version 1.1.2 Copyright (c) 2000-2013 the FFmpeg developers
  built on Feb 18 2013 15:43:59 with llvm-gcc 4.2.1 (LLVM build 2336.11.00)
  configuration: --disable-everything --enable-muxer=mp4 --enable-muxer=adts --enable-bsf=aac_adtstoasc --enable-demuxer=mov --enable-demuxer=h264 --enable-demuxer=aac --enable-protocol=file --enable-decoder=aac --enable-decoder=rawvideo --enable-decoder=h264 --enable-parser=h264 --enable-parser=aac
  libavutil      52. 13.100 / 52. 13.100
  libavcodec     54. 86.100 / 54. 86.100
  libavformat    54. 59.106 / 54. 59.106
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 32.100 /  3. 32.100
  libswscale      2.  1.103 /  2.  1.103
  libswresample   0. 17.102 /  0. 17.102

Attachments (1)

1.h264 (117.6 KB) - added by endlessroad1991 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by endlessroad1991

comment:1 Changed 7 years ago by endlessroad1991

Original fps of 1.h264 is 25.

comment:2 Changed 7 years ago by cehoyos

  • Keywords h264 added
  • Resolution set to duplicate
  • Status changed from new to closed

Afaict, this is a duplicate of ticket #2211.

Note: See TracTickets for help on using tickets.