Opened 5 years ago

Closed 5 years ago

#2258 closed enhancement (fixed)

allow -ss 30:00 instead of -ss 00:30:00

Reported by: compn Owned by:
Priority: wish Component: avutil
Version: git-master Keywords: duration format av_parse_time
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

ffmpeg -ss 00:30:00 to seek 30 minutes
be nice to just do ffmpeg -ss 30:00

same with -t

Change History (5)

comment:1 Changed 5 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
$ ffmpeg -ss 1:00 -i fate-suite/svq3/Vertical400kbit.sorenson3.mov
ffmpeg version N-49759-gcf8d9b7 Copyright (c) 2000-2013 the FFmpeg developers
  built on Feb 10 2013 09:22:04 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 17.101 / 52. 17.101
  libavcodec     54. 91.102 / 54. 91.102
  libavformat    54. 62.100 / 54. 62.100
  libavdevice    54.  3.103 / 54.  3.103
  libavfilter     3. 37.101 /  3. 37.101
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
Invalid duration specification for ss: 1:00

comment:2 follow-up: Changed 5 years ago by llogan

30:00 could possibly be interpreted by a user as 30 hours as it may resemble "clock" time. Perhaps 30 is fairly obvious, but not so much with 1:00 as an example.

comment:3 in reply to: ↑ 2 Changed 5 years ago by cehoyos

Replying to llogan:

30:00 could possibly be interpreted by a user as 30 hours as it may resemble "clock" time. Perhaps 30 is fairly obvious, but not so much with 1:00 as an example.

I don't disagree that it could be interpreted differently but 30 hour media files are at least unusual and since the syntax is currently not accepted at all I don't see how it could cause any (new) problems.

comment:4 follow-up: Changed 5 years ago by compn

no, -ss 30 is 30 seconds (and works in ffmpeg) you dont have to put -ss 00:00:30 to seek 30 seconds.

-ss 30:00 would be 30 minutes

clocks? we're talking about VCRs here...

comment:5 in reply to: ↑ 4 Changed 5 years ago by saste

  • Component changed from FFmpeg to avutil
  • Keywords duration format av_parse_time added
  • Resolution set to fixed
  • Status changed from open to closed

Replying to compn:

no, -ss 30 is 30 seconds (and works in ffmpeg) you dont have to put -ss 00:00:30 to seek 30 seconds.

-ss 30:00 would be 30 minutes

clocks? we're talking about VCRs here...

Fixed in:

commit 12a269a5229d3a37be0743fc9655f743ebc44b6e
Author: Senthilnathan M <senthilnathan.maadasamy@gmail.com>
Date:   Wed Feb 20 09:51:06 2013 +0530

    lavu/parseutils: allow MM:SS format for duration in av_parse_time()
    
    Fix trac ticket #2258.
    
    Signed-off-by: Senthilnathan M <senthilnathan.maadasamy@gmail.com>
    Signed-off-by: Stefano Sabatini <stefasab@gmail.com>
Note: See TracTickets for help on using tickets.