Opened 5 years ago

Closed 5 years ago

#1955 closed enhancement (fixed)

au: support g721 via g726 decoder

Reported by: ami_stuff Owned by: cehoyos
Priority: wish Component: avcodec
Version: git-master Keywords: g721 g726 sunau
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

"jack.au" plays ok with winamp/sox

file:

https://bugzilla.gnome.org/attachment.cgi?id=142681

info:

https://bugzilla.gnome.org/show_bug.cgi?id=594454

http://lists.freedesktop.org/archives/gstreamer-commits/2009-September/037444.html

C:\>ffmpeg -i jack.au
ffmpeg version N-46755-ge70144c Copyright (c) 2000-2012 the FFmpeg developers
  built on Nov 15 2012 02:38:20 with gcc 4.5.0 (GCC) 20100414 (Fedora MinGW 4.5.
0-1.fc14)
  configuration: --prefix=/var/www/users/research/ffmpeg/snapshots/build --arch=
x86 --target-os=mingw32 --cross-prefix=i686-pc-mingw32- --cc='ccache i686-pc-min
gw32-gcc' --enable-w32threads --enable-memalign-hack --enable-runtime-cpudetect
--enable-cross-compile --enable-static --disable-shared --extra-libs='-lws2_32 -
lwinmm -lpthread' --extra-cflags='--static -I/var/www/users/research/ffmpeg/snap
shots/build/include' --extra-ldflags='-static -L/var/www/users/research/ffmpeg/s
napshots/build/lib' --enable-bzlib --enable-zlib --enable-gpl --enable-version3
--enable-nonfree --enable-libx264 --enable-libspeex --enable-libtheora --enable-
libvorbis --enable-libfaac --enable-libxvid --enable-libopencore-amrnb --enable-
libopencore-amrwb --enable-libmp3lame --enable-libvpx --disable-decoder=libvpx
  libavutil      52.  6.100 / 52.  6.100
  libavcodec     54. 71.100 / 54. 71.100
  libavformat    54. 36.100 / 54. 36.100
  libavdevice    54.  3.100 / 54.  3.100
  libavfilter     3. 23.100 /  3. 23.100
  libswscale      2.  1.102 /  2.  1.102
  libswresample   0. 16.100 /  0. 16.100
  libpostproc    52.  1.100 / 52.  1.100
[au @ 0x1edc300] could not determine bits per sample
[au @ 0x1edc300] If you want to help, upload a sample of this file to ftp://uplo
ad.ffmpeg.org/MPlayer/incoming/ and contact the ffmpeg-devel mailing list.
jack.au: Invalid data found when processing input

Attachments (1)

g721.au (273.1 KB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by cehoyos

comment:1 Changed 5 years ago by cehoyos

  • Keywords g721 g726 sunau added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Patch sent to ffmpeg-devel, it produces the same broken output as GStreamer, sox works fine for the sample.

comment:2 Changed 5 years ago by ami_stuff

Thanks for the patch.

It turns out that Audition is able to save stereo au g721 files with various sampling frequencies and bitrates.

WinAMP plays all of the files correctly, SoX only mono.

http://www.datafilehost.com/download-a0cff049.html

comment:3 Changed 5 years ago by richardpl

  • Component changed from undetermined to avformat
  • Type changed from defect to enhancement

comment:4 Changed 5 years ago by cehoyos

  • Owner set to cehoyos

comment:5 Changed 5 years ago by cehoyos

  • Component changed from avformat to avcodec
  • Priority changed from normal to wish
  • Resolution set to fixed
  • Status changed from open to closed

Fixed in 640c70d.

Note: See TracTickets for help on using tickets.