Opened 5 years ago

Closed 5 years ago

#1954 closed enhancement (duplicate)

swscale: please support planar RGB (GBRP) output

Reported by: gjdfgh Owned by:
Priority: normal Component: swscale
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Planar RGB is surprisingly useful for algorithms that can work on both RGB and YUV colorspaces. (Especially if you want a cheap way to add RGB support to YUV code.) For these uses, it's really impractical that you can't use libswscale to convert input image data to GBRP.

Conversion to planar RGB should work with any input pixel format, and at least sws_isSupportedOutput(AV_PIX_FMT_GBRP) should return true.

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #1757.

Note: See TracTickets for help on using tickets.