Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1795 closed defect (wontfix)

configure --enable-filter=frei0r appears to not fail even if it can't build that filter

Reported by: rogerdpack Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

% ./configure --enable-memalign-hack --arch=x86 --enable-gpl --enable-libx264 --enable-avisynth --enable-libxvid --target-os=mingw32  --cross-prefix=/home/rogerdpack/dev/ffmpeg-windows-build-helpers/sandbox/mingw-w64-i686/bin/i686-w64-mingw32- --pkg-config=pkg-config --enable-libmp3lame --enable-version3 --enable-libvo-aacenc --enable-libvpx --extra-libs=-lws2_32 --extra-libs=-lpthread --enable-zlib --extra-libs=-lwinmm --extra-libs=-lgdi32 --enable-librtmp --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libopenjpeg --enable-gnutls --enable-libgsm --enable-libfreetype --disable-optimizations --enable-mmx --disable-postproc --enable-fontconfig --enable-libass --enable-libutvideo --enable-libopus --disable-w32threads --extra-cflags=-DPTW32_STATIC_LIB --enable-frei0r --enable-filter=frei0r --enable-runtime-cpudetect

...


Enabled filters:
aconvert crop pad
aevalsrc cropdetect pan
afifo decimate pixdesctest
aformat delogo removelogo
alphaextract deshake rgbtestsrc
alphamerge drawbox scale
amerge drawtext select
amix earwax sendcmd
amovie ebur128 setdar
anurll edgedetect setfield
anullsink fade setpts
anullsrc fieldorder setsar
aresample fifo settb
asendcmd format showinfo
asetnsamples fps showspectrum
asetpts framestep showwaves
asettb gradfun silencedetect
ashowinfo hflip slicify
asink hqdn3d smartblur
asink hue smptebars
asplit idet split
ass join super2xsai
astreamsync life swapuv
atempo lut testsrc
bbox lutrgb thumbnail
blackdetect lutyuv tile
blackframe mandelbrot tinterlace
boxblur movie transpose
cellauto mptestsrc unsharp
channelmap negate vflip
channelsplit noformat volume
color null volumedetect
colormatrix nullsink vsink
concat nullsrc vsink
copy overlay yadif

frei0r isn't listed (as dlopen isn't available, see attached config.log)

Attachments (1)

config.log (377.4 KB) - added by rogerdpack 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by rogerdpack

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #332.

comment:2 Changed 5 years ago by rogerdpack

Hmm. I posted this ticket after reading that #332 was closed because the last message was
" Marking this ticket as closed, since --enable-frei0r doesn't imply --enable-filter=frei0r." which I'm ok with--but this bug was that, even with --enable-filter=frei0r, configure didn't fail when it was missing dlopen. Or perhaps I'm missing something? shouldn't configure fail with --enable-filter=frei0r if it lacks dependencies? Suggest re-open or re-open 332.
Many thanks!

comment:3 Changed 5 years ago by rogerdpack

If there's nobody that could check and confirm this is a duplicate in a week I'll go ahead and reopen it, since it appears that it's not (viz previous comment). Thanks!
-roger-

comment:4 Changed 5 years ago by cehoyos

Before reopening, could you explain what the difference between ticket #332 and this one is?
Because I fail to find it...

comment:5 Changed 5 years ago by rogerdpack

#332's complaint was that "--enable-frei0r" didn't fail configure even if the frei0r filter failed to build (for instance, if it lacked dlopen). This one's complaint is that I would expect $ ./configure --enable-filter=frei0r to fail if it's unable to enable that filter, but it just seems to ignore it...if that makes sense at all :)

comment:6 Changed 5 years ago by cehoyos

  • Resolution changed from duplicate to wontfix

Yes, I am sorry, I misread the original description, this is not a duplicate of ticket #332.

For regression tests, it is important that the following configure line does not fail:

./configure --enable-filter=a_filter_that_does_not_exist

I would therefore object to a patch that changes the behaviour in this regard.

comment:7 Changed 5 years ago by rogerdpack

Ok, here's to hoping that eventually regression tests can be modified to allow for this :)

Note: See TracTickets for help on using tickets.