Opened 6 years ago

Closed 6 years ago

#332 closed defect (invalid)

configure accepts --enable-frei0r even if the dependencies are not met

Reported by: uidab Owned by: michael
Priority: minor Component: build system
Version: git-master Keywords: frei0r
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

I just try frei0r ,when I use it in Ubuntu, that is ok. But there are some mistakes in windows. The ffmpeg is downloaded from
http://ffmpeg.zeranoe.com/builds/

F:\ffmpeg-git-a304071-win32-shared\bin>ffmpeg.exe -i d:\aaaaaa.avi -vf frei0r=contrast0r:0.5 d:\bbb.
avi
FFmpeg version git-N-29181-ga304071, Copyright (c) 2000-2011 the FFmpeg developers
  built on Apr 18 2011 21:32:50 with gcc 4.5.2
  configuration: --disable-static --enable-shared --enable-gpl --enable-version3 --enable-runtime-cp
udetect --enable-memalign-hack --enable-avisynth --enable-bzlib --enable-frei0r --enable-libopencore
-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-
libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-
libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib --cross-p
refix=i686-w64-mingw32- --target-os=mingw32 --arch=x86_32 --extra-cflags=-I/home/kyle/software/ffmpe
g/external-libraries/win32/include --extra-ldflags=-L/home/kyle/software/ffmpeg/external-libraries/w
in32/lib --pkg-config=pkg-config
  libavutil    50. 40. 1 / 50. 40. 1
  libavcodec   52.120. 0 / 52.120. 0
  libavformat  52.108. 0 / 52.108. 0
  libavdevice  52.  4. 0 / 52.  4. 0
  libavfilter   1. 79. 0 /  1. 79. 0
  libswscale    0. 13. 0 /  0. 13. 0

Seems stream 0 codec frame rate differs from container frame rate: 30000.00 (30000/1) -> 29.97 (3000
0/1001)
Input #0, avi, from 'd:\aaaaaa.avi':
  Metadata:
    encoder         : Lavf52.64.2
  Duration: 00:04:52.79, start: 0.000000, bitrate: 280 kb/s
    Stream #0.0: Video: mpeg4, yuv420p, 272x288 [PAR 171:121 DAR 323:242], 29.97 fps, 29.97 tbr, 29.
97 tbn, 30k tbc
    Stream #0.1: Audio: mp2, 44100 Hz, stereo, s16, 64 kb/s
[buffer @ 00B9AC60] w:272 h:288 pixfmt:yuv420p
No such filter: 'frei0r'

I am sure that ffmpeg build with frei0r !! But I can't use it in windows?

What should I do?

Change History (6)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to build system
  • Priority changed from important to minor
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from Can't use frei0r filter in windows to configure accepts --enable-frei0r even if the dependencies are not met
  • Version changed from unspecified to git-master

frei0r has two dependencies in FFmpeg: dlopen and strtok_r. Since mingw fails on both, the frei0r filter is not compiled (look at the "Enabled filters:" section of configure's output).

I believe configure should reject --enable-frei0r if the filter cannot be compiled due to missing dependencies.

comment:2 follow-up: Changed 6 years ago by uidab

Configure don't reject --enable-frei0r
When I configure ffmpeg with --enable-frei0r
it shows

frei0r enabled yes

But I can't find frei0r in "Enabled filters:"

Enabled filters:
anull format pixdesctest
anullsink gradfun scale
anullsrc hflip setdar
blackframe hqdn3d setpts
buffer movie setsar
color mp settb
copy noformat slicify
crop null transpose
cropdetect nullsink unsharp
drawbox nullsrc vflip
fade overlay yadif
fifo pad

Where are dlopen and strtok_r?? Can you tell me?

comment:3 follow-up: Changed 6 years ago by KSHawkEye

frei0r didn't have any issues building, they could have somehow been silent, but it seemed to build just fine for both win32 and win64.

comment:4 in reply to: ↑ 3 Changed 6 years ago by uidab

Replying to KSHawkEye:

frei0r didn't have any issues building, they could have somehow been silent, but it seemed to build just fine for both win32 and win64.

It's so odd!!!

comment:5 in reply to: ↑ 2 Changed 6 years ago by cehoyos

Replying to uidab:

Where are dlopen and strtok_r?? Can you tell me?

Sure:
http://www.google.com/#q=mingw+dlopen
http://www.google.com/#q=mingw+strtok_r

comment:6 Changed 6 years ago by saste

  • Analyzed by developer set
  • Resolution set to invalid
  • Status changed from open to closed

Marking this ticket as closed, since --enable-frei0r doesn't imply --enable-filter=frei0r.

Indeed enabling frei0r only means to enable the library, frei0r library components are detected but the compilation of the frei0r filter is not enabled because of a different problem (likely missing strtok_r or dlopen).

Note: See TracTickets for help on using tickets.