Opened 5 years ago

Closed 5 years ago

#1413 closed defect (duplicate)

ffplay unable to playback MJPEG avi file

Reported by: Kraken Owned by:
Priority: important Component: ffmpeg
Version: git-master Keywords:
Cc: cus@passwd.hu Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

http://light-alloy.ru/aleksoid_test/SUNP0003.AVI
Picture freeze, a lot of red text in console window.
avplay - can play it, but cannot seek.

Change History (4)

comment:1 Changed 5 years ago by cus

  • Analyzed by developer set
  • Cc cus@passwd.hu added
  • Reproduced by developer set

Changing pixel format with avfilter enabled is not supported yet in ffplay. (Nor in avplay btw)

comment:2 follow-up: Changed 5 years ago by Kraken

(Nor in avplay btw)

Wouldn't argue, but if with avplay I can at least see video and listen sound, with ffplay I only see freeze video and listen loop sound.
Just, my media player for Windows, which use libavcodec, is crashing when I try to playback this file, because of libswscale. So I tryed to check this file in ffplay, and see that problem not in my code, so I assumed its a ffmpeg bug.

Changing pixel format with avfilter enabled

Hm. Pixel format is changing when I try to play this file? (my media player doesn't use avfilter)

Sorry for my bad English.

comment:3 in reply to: ↑ 2 Changed 5 years ago by cus

Replying to Kraken:

Changing pixel format with avfilter enabled

Hm. Pixel format is changing when I try to play this file? (my media player doesn't use avfilter)

Yes, that may be reason why swscale crashes for you. See ffplay.c with CONFIG_LIBAVFILTER set to 0, it gets a cached swscaler context for each frame because of possibly changing pixel format.

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #238.

Note: See TracTickets for help on using tickets.