Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#126 closed defect (fixed)

h263 seeking / decoding problem

Reported by: ami_stuff Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: h263
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

there are visible green gfx bugs while playing the file with ffplay

most likely libavfilter-caused regression

while seeking the video, the area outside of the vid is changing as well - most likely this is also libavfilter-caused regression

http://www.datafilehost.com/download-1a866460.html

C:\>ffmpeg -i C:\r-2002-30.mov
FFmpeg version git-N-29181-ga304071, Copyright (c) 2000-2011 the FFmpeg develope
rs
  built on Apr 18 2011 21:24:03 with gcc 4.5.2
  configuration: --enable-gpl --enable-version3 --enable-runtime-cpudetect --ena
ble-memalign-hack --enable-avisynth --enable-bzlib --enable-frei0r --enable-libo
pencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --
enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger
 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enabl
e-libx264 --enable-libxavs --enable-libxvid --enable-zlib --cross-prefix=i686-w6
4-mingw32- --target-os=mingw32 --arch=x86_32 --extra-cflags=-I/home/kyle/softwar
e/ffmpeg/external-libraries/win32/include --extra-ldflags=-L/home/kyle/software/
ffmpeg/external-libraries/win32/lib --pkg-config=pkg-config
  libavutil    50. 40. 1 / 50. 40. 1
  libavcodec   52.120. 0 / 52.120. 0
  libavformat  52.108. 0 / 52.108. 0
  libavdevice  52.  4. 0 / 52.  4. 0
  libavfilter   1. 79. 0 /  1. 79. 0
  libswscale    0. 13. 0 /  0. 13. 0

Seems stream 0 codec frame rate differs from container frame rate: 29.97 (30000/
1001) -> 15.00 (15/1)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\r-2002-30.mov':
  Metadata:
    creation_time   : 2001-08-08 17:13:07
  Duration: 00:03:27.66, start: 0.000000, bitrate: 811 kb/s
    Stream #0.0(eng): Video: h263, yuv420p, 352x288 [PAR 12:11 DAR 4:3], 435 kb/
s, 15 fps, 15 tbr, 1500 tbn, 29.97 tbc
    Metadata:
      creation_time   : 2001-08-08 17:13:07
    Stream #0.1(eng): Audio: adpcm_ima_qt, 44100 Hz, 2 channels, s16
    Metadata:
      creation_time   : 2001-08-08 17:13:07
At least one output file must be specified

Change History (12)

comment:1 Changed 6 years ago by ami_stuff

please seek a few times with the mouse to reproduce gfx bugs on the video area

comment:2 Changed 6 years ago by cehoyos

The issue has improved: The areas outside the encoded image are now solid grey instead of green memory dumps, but after seeking, those areas still "leak" into the picture on panning.

comment:3 Changed 6 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:4 Changed 6 years ago by michael

i cant reproduce this

comment:5 Changed 6 years ago by ami_stuff

seems to be fixed for me (can't reproduce it anymore)

comment:6 Changed 6 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

Closing as it seems to have been fixed somehow by something

comment:7 Changed 6 years ago by ami_stuff

  • Resolution fixed deleted
  • Status changed from closed to reopened
The issue has improved: The areas outside the encoded image are now solid grey
instead of green memory dumps, but after seeking, those areas still "leak" into
the picture on panning.

The issue can be reproduced now with:

ffmpeg -ss 1 -i r-2002-30.mov out.avi

or

ffplay -ss 1 r-2002-30.mov

so I re-open this ticket.

comment:8 Changed 6 years ago by cehoyos

  • Status changed from reopened to open

The areas outside the encoded image are now solid grey instead of green memory dumps (as when the ticket was originally opened), but after seeking, those areas still "leak" into the picture on panning.

comment:9 Changed 5 years ago by michael

This video does only conatin 1 keyframe
the other "keyframes" arent real ones
it only decodes correctly if the first frame has been decoded before seeking.

comment:10 Changed 5 years ago by cehoyos

  • Summary changed from ffplay - h263 codec playback regression to h263 seeking / decoding problem

After seeking, mplayer -demuxer lavf -vc ffh263 shows some artefacts that disappear quickly.
ffmpeg -ss 1 -i r-2002-30.mov -an -qscale 2 out.avi produces a file that constantly shows the "leaking" of the grey surrounding into the actual video.
(Not a regression, afaict.)

comment:11 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

Fixed locally, ill push after tests

comment:12 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords h263 added
Note: See TracTickets for help on using tickets.