Opened 7 years ago

Closed 4 years ago

#113 closed enhancement (fixed)

AAC - Audio object type 23 is not supported

Reported by: k_s_johnson Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: AAC-LD
Cc: batguano999@hotmail.com Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

ffmpeg AAC codec (decoder) doesn't seem to support AAC-LD and libfaad or libfaad2 (which is documented to support AAC-LD) is no longer an audio codec option. So there is no way to decode AAC-LD format audio track anymore. However, vlc on windows seems to play the file

ffmpeg build from git snapshot of a few days ago( ffmpeg-HEAD-e16665b) on Fedora 2.6.30.9-96.fc11.x86_6411.

command line:
ffmpeg -y -i po_arrive...mov -acodec pcm_s24le extracted.wav

Error message is:
[aac @ 0x1e9bfa0] Audio object type 23 is not supported.

Attachments (3)

po_arrive_early_michelle_021811.S_mxf.log (1.8 KB) - added by k_s_johnson 7 years ago.
ffmpeg output log
po_arrive_early_michelle_021811_fs_trunc.mov (2.0 MB) - added by k_s_johnson 7 years ago.
Input file truncated after processing with qt-faststart
foo.m4a (246.1 KB) - added by bat_guano 5 years ago.

Change History (14)

Changed 7 years ago by k_s_johnson

ffmpeg output log

comment:1 follow-up: Changed 7 years ago by cehoyos

  • Status changed from new to open

The sample you uploaded doesn't work, use qt-faststart to produce a sample that you can cut with dd.

Changed 7 years ago by k_s_johnson

Input file truncated after processing with qt-faststart

comment:2 in reply to: ↑ 1 Changed 7 years ago by k_s_johnson

Replying to cehoyos:

The sample you uploaded doesn't work, use qt-faststart to produce a sample that you can cut with dd.

Uploaded new input file processed with qt-faststart and cut with dd.

comment:3 follow-up: Changed 7 years ago by cehoyos

  • Reproduced by developer set
  • Type changed from defect to enhancement
  • Version changed from git to git-master

Changed 5 years ago by bat_guano

comment:4 in reply to: ↑ 3 Changed 5 years ago by bat_guano

Replying to cehoyos:
Hi
This AAC-LD profile can be achieved using libfdk_aac encoder with FFmpeg:-
$ ffmpeg -i foo -c:a libfdk_aac -profile:a aac_ld -b:a 64k -ar 44100 -ac 2 foo.m4a
Sample is attached.

comment:5 Changed 5 years ago by bat_guano

  • Cc batguano999@hotmail.com added

comment:6 Changed 5 years ago by bat_guano

Hi
libfdk_aac has a AAC-LD decoder.
Could FFmpeg be made to use this?

comment:7 Changed 5 years ago by richardpl

  • Priority changed from normal to wish

comment:8 Changed 4 years ago by Timothy_Gu

This should be fixed in 4f2b469da5e4ae221718ae479f6af627cfdebb91/614cf1a6133a143961798c5d87c9bffc2ca0da9e by Martin Storsjö.

Please close this ticket.

Last edited 4 years ago by Timothy_Gu (previous) (diff)

comment:9 Changed 4 years ago by cehoyos

The issue is still reproducible afaict.

comment:10 Changed 4 years ago by richardpl

This is ticket for native decoder. Thus this ticket will remain open.

comment:11 Changed 4 years ago by richardpl

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in 32ea39f56d9 / 1914e6f010b332.

Note: See TracTickets for help on using tickets.