Opened 10 years ago

Closed 10 years ago

#1055 closed defect (fixed)

Playing wmalossless/decoding it to mp3 there is a loud noise at the end of the file

Reported by: bfo Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: wmalossless
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I am trying to transcode from WMA Lossless to anything else, but this bug report desribes transcoding to MP3 problems. Transcoding to OGG/Flac results in the same anyway.
Playing file anywhere, be it VLC, Qmmp, Clementine, ffplay, there is a loud static noise at the end of the file. The static is also present when I play the original wma file in ffplay. File itself is not broken, because WMP 11/Win7 plays them w/o much hassle.
CLI action used for transcoding:

ffmpeg -report -v 9 -loglevel 99 -i 25_Sciezka_25.wma 25_Sciezka_25.mp3

As an attachment I am sending both the original file and the transcoded one, plus logfile of the conversion process.

Attachments (4)

ffmpeg-20120311-154657.log (41.1 KB ) - added by bfo 10 years ago.
Log file
03_Track_3.wma (2.4 MB ) - added by bfo 10 years ago.
Original WMA file
ffmpeg-20120311-154567.log (31.8 KB ) - added by bfo 10 years ago.
03_Track_3.mp3 (489.7 KB ) - added by bfo 10 years ago.
Transcoded file

Change History (7)

by bfo, 10 years ago

Attachment: ffmpeg-20120311-154657.log added

Log file

by bfo, 10 years ago

Attachment: 03_Track_3.wma added

Original WMA file

by bfo, 10 years ago

Attachment: ffmpeg-20120311-154567.log added

by bfo, 10 years ago

Attachment: 03_Track_3.mp3 added

Transcoded file

comment:1 by bfo, 10 years ago

First attachment is invalid, as that is logfile from conversion of the file, that was to large to upload it here, and it could not be truncated due to the nature of the problem.

comment:2 by Carl Eugen Hoyos, 10 years ago

Component: FFmpegavcodec
Keywords: wma convert noise removed
Reproduced by developer: set
Status: newopen
Version: unspecifiedgit-master

For future bug reports: Please do not use other software (in your case libmp3lame) to test ffmpeg if this is not necessary; for audio decoding reports, I believe decoding to wav is preferred.
Attaching the output file is usually not necessary.

out.wav has the described severe audible artefacts after 30 seconds.

$ ffmpeg -i 03_Track_3.wma out.wav
ffmpeg version N-38726-gad029c2 Copyright (c) 2000-2012 the FFmpeg developers
  built on Mar 11 2012 16:49:53 with gcc 4.3.2
  configuration: --cc=/usr/local/gcc-4.3.2/bin/gcc --enable-gpl
  libavutil      51. 42.100 / 51. 42.100
  libavcodec     54. 10.100 / 54. 10.100
  libavformat    54.  2.100 / 54.  2.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 64.101 /  2. 64.101
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  7.100 /  0.  7.100
  libpostproc    52.  0.100 / 52.  0.100
Input #0, asf, from '03_Track_3.wma':
  Metadata:
    WM/MediaPrimaryClassID: {D1607DBC-E323-4BE2-86A1-48A42A28441E}
    WMFSDKVersion   : 11.0.5721.5275
    WMFSDKNeeded    : 0.0.0.0000
    WM/EncodingTime : 1844674
    PeakValue       : 292
    AverageLevel    : 396
    track           : 3
    WM/UniqueFileIdentifier: ;
    WM/Provider     : User Feedback
    album           : Schritte International 5
    album_artist    : Hueber
    genre           : Miscellaneous
    IsVBR           : 1
    MediaFoundationVersion: 2.112
    title           : Track 3
    artist          : Hueber
  Duration: 00:00:31.98, start: 0.000000, bitrate: 618 kb/s
    Stream #0:0(eng): Audio: wmalossless (c[1][0][0] / 0x0163), 44100 Hz, stereo, s16, 1152 kb/s
Output #0, wav, to 'out.wav':
  Metadata:
    WM/MediaPrimaryClassID: {D1607DBC-E323-4BE2-86A1-48A42A28441E}
    WMFSDKVersion   : 11.0.5721.5275
    WMFSDKNeeded    : 0.0.0.0000
    WM/EncodingTime : 1844674
    PeakValue       : 292
    AverageLevel    : 396
    track           : 3
    WM/UniqueFileIdentifier: ;
    WM/Provider     : User Feedback
    album           : Schritte International 5
    album_artist    : Hueber
    genre           : Miscellaneous
    IsVBR           : 1
    MediaFoundationVersion: 2.112
    title           : Track 3
    artist          : Hueber
    encoder         : Lavf54.2.100
    Stream #0:0(eng): Audio: pcm_s16le ([1][0][0][0] / 0x0001), 44100 Hz, stereo, s16, 1411 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (wmalossless -> pcm_s16le)
Press [q] to stop, [?] for help
Multiple frames in a packet from stream 0
DTS 1346, next:1484512 st:0 invalid droping
DTS 1532, next:1716707 st:0 invalid droping
DTS 1717, next:1902463 st:0 invalid droping
DTS 1856, next:2088219 st:0 invalid droping
DTS 2043, next:2227536 st:0 invalid droping

...

DTS 27120, next:27258157 st:0 invalid droping
DTS 27306, next:27490352 st:0 invalid droping
DTS 27538, next:27676108 st:0 invalid droping
DTS 27770, next:27908303 st:0 invalid droping
DTS 28002, next:28140498 st:0 invalid droping
DTS 28281, next:28372693 st:0 invalid droping
size=    5384kB time=00:00:31.25 bitrate=1411.2kbits/s
video:0kB audio:5384kB global headers:0kB muxing overhead 0.000834%

comment:3 by Carl Eugen Hoyos, 10 years ago

Resolution: fixed
Status: openclosed

Fixed by Jakub Stachowski.

Note: See TracTickets for help on using tickets.