Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#6228 closed enhancement (duplicate)

Output HLS (fMP4) from DASH muxer

Reported by: alqemyst Owned by:
Priority: wish Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

I need someone to guide me on this one. Dash muxer creates .m4s fragmets per adaptation set and creates manifest. I want to write additional .m3u8 playlist per adaptation set and include all .m4s fragmets in provided window size. This way it would be possible to output both MPEG-DASH and HLS (fMP4) protocols by just manually creating master.m3u8 which contains adaptaion set .m3u8 lists.

Do you think this is the right way to do it? I would make additional function called write_m3u8() then call it in write_manifest() function first inside loop for video streams, then for audio streams.

Change History (4)

comment:1 Changed 8 months ago by cehoyos

Isn't this a duplicate of ticket #5699?

comment:2 Changed 8 months ago by alqemyst

Exactly. Sorry for duplicating issue.

In my opinion it should be done through dashenc.c since there are already m4s segments. Maybe dash muxer should have additional option to enable output to adaptation m3u8 playlist. Please let me know how I can help.

comment:3 Changed 8 months ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

A patch is typically most welcome!

comment:4 Changed 8 months ago by alqemyst

Thanks, I'll submit in couple of days my version to patchwork, then we can discuss.

Note: See TracTickets for help on using tickets.